Closed Bug 751950 Opened 9 years ago Closed 9 years ago

Sync Key not being loaded for initial sync

Categories

(Firefox :: Sync, defect)

defect
Not set
normal

Tracking

()

VERIFIED FIXED
mozilla15

People

(Reporter: gps, Assigned: gps)

References

Details

Attachments

(1 file)

It looks like the initial sync operation is not detecting the Sync Key. However, subsequent syncs seem to pull it in. This is likely a regression from bug 730989. Although, it could be a regression from bug 749957.
Attached patch DerpSplinter Review
It was a regression from bug 749957. My optimization in the implementation of currentAuthState was a bit premature. This change will cause a known invalid Sync Key to try to be derived into a bundle on each call to currentAuthState. But, I think that's simpler than maintaining state in the instance.

Alternatively, we could fetch this.syncKeyBundle from the syncKey getter. Meh.
Assignee: nobody → gps
Status: NEW → ASSIGNED
Attachment #621108 - Flags: review?(rnewman)
Each restart of the browser requires entering the Recovery Key in the Update dialog in response to the Wrong Recover Key dialog (if you know to go look at Sync Prefs)  Otherwise, sync does not connect.
Severity: normal → critical
Comment on attachment 621108 [details] [diff] [review]
Derp

Review of attachment 621108 [details] [diff] [review]:
-----------------------------------------------------------------

Hurr.
Attachment #621108 - Flags: review?(rnewman) → review+
https://hg.mozilla.org/integration/mozilla-inbound/rev/ac9db6e7b6b8

I'll roll this into bug 749957 when that gets uplifted to Aurora.
Severity: critical → normal
https://hg.mozilla.org/mozilla-central/rev/ac9db6e7b6b8
Status: ASSIGNED → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla15
Duplicate of this bug: 752256
with m-c merged back to s-c, I verified this as part of the client train this week.
Status: RESOLVED → VERIFIED
Component: Firefox Sync: Backend → Sync
Product: Cloud Services → Firefox
You need to log in before you can comment on or make changes to this bug.