Last Comment Bug 751951 - laggy display of large images in B2G on Nexus S
: laggy display of large images in B2G on Nexus S
Status: VERIFIED FIXED
: qawanted
Product: Core
Classification: Components
Component: Graphics (show other bugs)
: Trunk
: ARM Gonk (Firefox OS)
: P2 normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
: Matt Brandt [:mbrandt]
Mentors:
Depends on:
Blocks: 777259
  Show dependency treegraph
 
Reported: 2012-05-04 10:48 PDT by David Flanagan [:djf]
Modified: 2012-08-13 10:37 PDT (History)
13 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
+
-


Attachments

Description David Flanagan [:djf] 2012-05-04 10:48:29 PDT
In the Gaia Gallery app, most of the images are just demos and are only as large as the phone's screen. In a recent update, however, I added some larger images in various aspect ratios.

The last image in the current gallery (a b/w photo of a boat) is 2169x1613.  (The next largest image in the gallery is 1024x1010). On the Nexus S there is a noticeable lag in displaying this large image.  If you pan from the image before to it, there is blank screen before it appears.  If you pan slowly between this image and the small one before it, the small one moves smoothly left and right, but the big one appears and disappears.  

I've tried moving this large image so that it is not the last one in the gallery, to verify that it is the image size and not its placement that is causing the problem.  And I've tried another large (2592x1944) image and get the same problem, so it is not something specific about that particular jpeg.

I'm guessing that cjones is the right person to assign this to, based on #737071.
Comment 1 David Flanagan [:djf] 2012-05-04 10:59:55 PDT
dhylands reports that there is a lag of about 1/2 second to display the large image on the SGS2, but that panning side to side works fine on that hardware.
Comment 2 David Flanagan [:djf] 2012-05-04 11:13:10 PDT
A clarification and a hint:

1) after further testing, dhylands thinks that the lag he's seeing on the sgs2 is just loadtime lag, not the same thing I'm seeing on the nexus s.

2) When I pinch to zoom into this big image, it resizes smoothly, and I can pan smoothly around within the image.  The but does not occur until I reach the edge of the image. This puts the gallery into a new mode where it is starting to pan between two different images.  It does this with a -moz-transform to translate left or right.  So I suspect the bug has something to do with the transform.
Comment 3 Joe Drew (not getting mail) 2012-05-04 11:21:08 PDT
Please profile this, so we know what we're spending time doing.
Comment 4 David Flanagan [:djf] 2012-05-04 11:43:48 PDT
(In reply to Joe Drew (:JOEDREW!) from comment #3)
> Please profile this, so we know what we're spending time doing.

I have no idea how to profile it. Sorry.
Comment 5 Chris Jones [:cjones] inactive; ni?/f?/r? if you need me 2012-05-04 12:20:14 PDT
Point of order: it's bad style to assign bugs to folks unless you've talked to them beforehand.  In bugzilla, "Assigned" means "Yes, I'm working on this", sort of like a resource lock.  Fyi, no worries here :).

Comment 3 is the way to start.
Comment 6 David Flanagan [:djf] 2012-05-04 12:59:35 PDT
cjones: Sorry about that. You weren't on IRC at the time and I saw a similar graphics bug assigned to you. I should have known to cc you not assign you, though.
Comment 7 David Flanagan [:djf] 2012-06-12 12:15:24 PDT
I can still reproduce this (though it doesn't seem as bad as it used to be) in the new DeviceStorage-based gallery app, using sample photos from the camera app.
Comment 8 Dietrich Ayala (:dietrich) 2012-06-12 13:09:34 PDT
This is super janky on Nexus S. Adding QA to verify whether it's a problem on Otoro as well. John, ping David for sample photos.
Comment 9 Geo Mealer [:geo] -- This account is inactive after 2015-07-07 2012-07-24 13:06:25 PDT
Will check on Otoro this aft and update bug
Comment 10 Geo Mealer [:geo] -- This account is inactive after 2015-07-07 2012-07-24 17:28:58 PDT
Need to bump verification to tomorrow--don't have a device available today.
Comment 11 Matt Brandt [:mbrandt] 2012-07-26 15:20:26 PDT
 (In reply to Geo Mealer [:geo] from comment #9)
> Will check on Otoro this aft and update bug

It appears that there is a recent issue where device storage is returning a null - bug 777259 - I suggest we block checking for reproducibility on Otoro devices until this is resolved.
Comment 12 Andreas Gal :gal 2012-08-08 10:02:34 PDT
How are we doing here? The lag might be in part too long time slices for image decoding on the main thread, which you can control with a pref.
Comment 13 Andreas Gal :gal 2012-08-08 15:24:29 PDT
Renom if you think we can't ship a v1 without this.
Comment 14 Jason Smith [:jsmith] 2012-08-08 16:15:57 PDT
Per IRC conversations with a few other folks, I think the best course of action if there is disagreement on whether this blocks or not is to do the following:

- Move the blocking-basecamp flag to ? for re-evaluation
- Indicate a rationale for why you disagree
Comment 15 Matt Brandt [:mbrandt] 2012-08-10 09:32:39 PDT
bug 777259 (Device Storage returning null object) has been resolved -- I'm unaware of what was resolved in irc (comment 14) but I will try to reproduce the behavior in comment 0 on otoro when it lands.

:djf can you also retest on your Nexus S?
Comment 16 David Flanagan [:djf] 2012-08-10 10:42:02 PDT
:mbrandt I can't reproduce this on the nexus s anymore.

Note that you don't have to wait for 777259 to land. The workaround is to launch Gallery.  Long press home to bring up the task switcher.  Swipe up to kill gallery.  Then restart it.  After a pause it will find the images.
Comment 17 Matt Brandt [:mbrandt] 2012-08-10 10:55:58 PDT
Hot .. thanks :djf -- bumping to resolved fixed per comment 16.
Comment 18 Matt Brandt [:mbrandt] 2012-08-10 11:20:40 PDT
Marking QA verified -- spoke to :djf in channel and neither of us are able to reproduce this on Otoro.

Thanks :djf

Note You need to log in before you can comment on or make changes to this bug.