The default bug view has changed. See this FAQ.

laggy display of large images in B2G on Nexus S

VERIFIED FIXED

Status

()

Core
Graphics
P2
normal
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: djf, Unassigned)

Tracking

({qawanted})

Trunk
ARM
Gonk (Firefox OS)
qawanted
Points:
---

Firefox Tracking Flags

(blocking-kilimanjaro:+, blocking-basecamp:-)

Details

(Reporter)

Description

5 years ago
In the Gaia Gallery app, most of the images are just demos and are only as large as the phone's screen. In a recent update, however, I added some larger images in various aspect ratios.

The last image in the current gallery (a b/w photo of a boat) is 2169x1613.  (The next largest image in the gallery is 1024x1010). On the Nexus S there is a noticeable lag in displaying this large image.  If you pan from the image before to it, there is blank screen before it appears.  If you pan slowly between this image and the small one before it, the small one moves smoothly left and right, but the big one appears and disappears.  

I've tried moving this large image so that it is not the last one in the gallery, to verify that it is the image size and not its placement that is causing the problem.  And I've tried another large (2592x1944) image and get the same problem, so it is not something specific about that particular jpeg.

I'm guessing that cjones is the right person to assign this to, based on #737071.
(Reporter)

Comment 1

5 years ago
dhylands reports that there is a lag of about 1/2 second to display the large image on the SGS2, but that panning side to side works fine on that hardware.
(Reporter)

Comment 2

5 years ago
A clarification and a hint:

1) after further testing, dhylands thinks that the lag he's seeing on the sgs2 is just loadtime lag, not the same thing I'm seeing on the nexus s.

2) When I pinch to zoom into this big image, it resizes smoothly, and I can pan smoothly around within the image.  The but does not occur until I reach the edge of the image. This puts the gallery into a new mode where it is starting to pan between two different images.  It does this with a -moz-transform to translate left or right.  So I suspect the bug has something to do with the transform.
Please profile this, so we know what we're spending time doing.
(Reporter)

Comment 4

5 years ago
(In reply to Joe Drew (:JOEDREW!) from comment #3)
> Please profile this, so we know what we're spending time doing.

I have no idea how to profile it. Sorry.
Point of order: it's bad style to assign bugs to folks unless you've talked to them beforehand.  In bugzilla, "Assigned" means "Yes, I'm working on this", sort of like a resource lock.  Fyi, no worries here :).

Comment 3 is the way to start.
Assignee: jones.chris.g → nobody
(Reporter)

Comment 6

5 years ago
cjones: Sorry about that. You weren't on IRC at the time and I saw a similar graphics bug assigned to you. I should have known to cc you not assign you, though.
(Reporter)

Comment 7

5 years ago
I can still reproduce this (though it doesn't seem as bad as it used to be) in the new DeviceStorage-based gallery app, using sample photos from the camera app.
This is super janky on Nexus S. Adding QA to verify whether it's a problem on Otoro as well. John, ping David for sample photos.
blocking-basecamp: --- → +
blocking-kilimanjaro: --- → +
Priority: -- → P1

Updated

5 years ago
Keywords: qawanted
Will check on Otoro this aft and update bug
Need to bump verification to tomorrow--don't have a device available today.
 (In reply to Geo Mealer [:geo] from comment #9)
> Will check on Otoro this aft and update bug

It appears that there is a recent issue where device storage is returning a null - bug 777259 - I suggest we block checking for reproducibility on Otoro devices until this is resolved.
Blocks: 777259

Comment 12

5 years ago
How are we doing here? The lag might be in part too long time slices for image decoding on the main thread, which you can control with a pref.

Updated

5 years ago
Priority: P1 → P2

Comment 13

5 years ago
Renom if you think we can't ship a v1 without this.
blocking-basecamp: + → ---
Per IRC conversations with a few other folks, I think the best course of action if there is disagreement on whether this blocks or not is to do the following:

- Move the blocking-basecamp flag to ? for re-evaluation
- Indicate a rationale for why you disagree
blocking-basecamp: --- → ?

Updated

5 years ago
QA Contact: mbrandt
bug 777259 (Device Storage returning null object) has been resolved -- I'm unaware of what was resolved in irc (comment 14) but I will try to reproduce the behavior in comment 0 on otoro when it lands.

:djf can you also retest on your Nexus S?
(Reporter)

Comment 16

5 years ago
:mbrandt I can't reproduce this on the nexus s anymore.

Note that you don't have to wait for 777259 to land. The workaround is to launch Gallery.  Long press home to bring up the task switcher.  Swipe up to kill gallery.  Then restart it.  After a pause it will find the images.
Hot .. thanks :djf -- bumping to resolved fixed per comment 16.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Marking QA verified -- spoke to :djf in channel and neither of us are able to reproduce this on Otoro.

Thanks :djf
Status: RESOLVED → VERIFIED
blocking-basecamp: ? → -
You need to log in before you can comment on or make changes to this bug.