All users were logged out of Bugzilla on October 13th, 2018

java.lang.NullPointerException: at org.mozilla.gecko.sync.repositories.android.PasswordsRepositorySession.finish(PasswordsRepositorySession.java)

RESOLVED DUPLICATE of bug 745837

Status

()

--
critical
RESOLVED DUPLICATE of bug 745837
7 years ago
2 years ago

People

(Reporter: scoobidiver, Unassigned)

Tracking

({crash})

15 Branch
ARM
Android
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [native-crash], sync, crash signature)

(Reporter)

Description

7 years ago
There are two crashes from the same user in 15.0a1/20120504: bp-fd4a1195-9def-433f-91b5-385b02120504.

java.lang.NullPointerException
	at org.mozilla.gecko.sync.repositories.android.PasswordsRepositorySession.finish(PasswordsRepositorySession.java:421)
	at org.mozilla.gecko.sync.synchronizer.SynchronizerSession.onFinishSucceeded(SynchronizerSession.java:363)
	at org.mozilla.gecko.sync.middleware.MiddlewareRepositorySession$MiddlewareRepositorySessionFinishDelegate.onFinishSucceeded(MiddlewareRepositorySession.java:98)
	at org.mozilla.gecko.sync.repositories.RepositorySession.finish(RepositorySession.java:240)
	at org.mozilla.gecko.sync.middleware.MiddlewareRepositorySession.finish(MiddlewareRepositorySession.java:109)
	at org.mozilla.gecko.sync.synchronizer.SynchronizerSession.onFlowCompleted(SynchronizerSession.java:202)
	at org.mozilla.gecko.sync.synchronizer.RecordsChannel.onStoreCompleted(RecordsChannel.java:219)
	at org.mozilla.gecko.sync.repositories.RepositorySession$1.run(RepositorySession.java:130)
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1088)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:581)
	at java.lang.Thread.run(Thread.java:1019)

More reports at:
https://crash-stats.mozilla.com/report/list?signature=java.lang.NullPointerException%3A+at+org.mozilla.gecko.sync.repositories.android.PasswordsRepositorySession.finish%28PasswordsRepositorySession.java%29

Updated

7 years ago
Whiteboard: [native-crash] → [native-crash], sync
Apparently the passwords content provider doesn't work on the InfoBar A01.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 745837
You need to log in before you can comment on or make changes to this bug.