support XPCOM_DEBUG_BREAK=warn on Win32

RESOLVED FIXED in mozilla0.9.1

Status

()

Core
XPCOM
RESOLVED FIXED
17 years ago
17 years ago

People

(Reporter: Chris Waterson, Assigned: Chris Waterson)

Tracking

Trunk
mozilla0.9.1
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

17 years ago
Win32 should support the XPCOM_DEBUG_BREAK environment variable: when set to 
``warn'', we should *not* trap into the debugger; we should just print the 
console error message and return.

(This is useful e.g. for automating the layout regression tests.)
(Assignee)

Comment 1

17 years ago
Created attachment 30120 [details] [diff] [review]
handle XPCOM_DEBUG_BREAK=warn
(Assignee)

Updated

17 years ago
Status: NEW → ASSIGNED
Target Milestone: --- → mozilla0.9.1
(Assignee)

Updated

17 years ago
Blocks: 62589

Updated

17 years ago
Keywords: patch
(Assignee)

Comment 2

17 years ago
kandrot, could you r=? scc, sr=?
(Assignee)

Updated

17 years ago
Keywords: donttest

Comment 3

17 years ago
*** Bug 77424 has been marked as a duplicate of this bug. ***
I can r= this -- I'm well-known to be in favor of XP assertion behavior, and
this is a small step in that direction.

/be
(Assignee)

Comment 5

17 years ago
Fix checked in. scc, you sr='d.
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.