http://www.mozilla.org/en-US/firefox/new/ on Android gives link to download Firefox for Linux

VERIFIED DUPLICATE of bug 750555

Status

VERIFIED DUPLICATE of bug 750555
7 years ago
6 years ago

People

(Reporter: retornam, Assigned: rik)

Tracking

unspecified
x86
Android
Bug Flags:
in-testsuite ?

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
STR:
1) Visit http://www.mozilla.org/en-US/firefox/new/ on any Android device.  The download button is for Firefox for linux and not Android.


Expected Results:
1) The link should be for Firefox Mobile on Android



This problem has to do with the way we do redirects. Currently visiting http://www.mozilla.org/en-US/firefox/  redirects you to either 
http://www.mozilla.org/en-US/firefox/new/ or http://www.mozilla.org/en-US/firefox/fx based on your user agent as well as the version of Firefox you are running. We need to have a check for users who visit http://www.mozilla.org/en-US/firefox/new/  and http://www.mozilla.org/en-US/firefox/fx  directly so we show the correct download buttons.

For example visiting http://www.mozilla.org/en-US/firefox/fx  in Chrome will show a page that says your Firefox is up to date.

Comment 1

7 years ago
Rik: Can you work on getting this resolved the week of May 7th and over to QA to verify for an upcoming release? Thanks!
Assignee: nobody → anthony
Target Milestone: --- → 2.5
Let's also get automation (maybe using requests, in Python) to help prevent this bug's recurrence.
Flags: in-testsuite?

Comment 3

7 years ago
(In reply to Chris More [:cmore] from comment #1)
> Rik: Can you work on getting this resolved the week of May 7th and over to
> QA to verify for an upcoming release? Thanks!

Anthony...ping?

Comment 4

7 years ago
Raymond: Just to confirm, all the other changes that we made in the past few days to redirects and button fixes, does not affect this bug? Can you confirm it still exists?
(Assignee)

Comment 5

7 years ago
It should be fixed on http://www-dev.allizom.org/en-US/firefox/new/

AFAICT, this is a duplicate of bug 750555. Reopen if I'm mistaken.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 750555
(Reporter)

Comment 6

7 years ago
Yeah this is fixed on production. The only thing broken right now is the http://www-dev.allizom.org/en-US/?mobile_no_redirect=1 redirect bug which James is working on
Status: RESOLVED → UNCONFIRMED
Ever confirmed: false
Resolution: DUPLICATE → ---
(Reporter)

Updated

7 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 750555
Verified duplicate
Status: RESOLVED → VERIFIED
OS: Mac OS X → Android
Component: www.mozilla.org → General
Product: Websites → www.mozilla.org
Restoring unintended removal of in-testsuite flag.
Flags: in-testsuite?
You need to log in before you can comment on or make changes to this bug.