Local folders and messages missing

RESOLVED DUPLICATE of bug 752085

Status

RESOLVED DUPLICATE of bug 752085
7 years ago
7 years ago

People

(Reporter: kevinf2002, Unassigned)

Tracking

11 Branch
x86_64
Windows 7

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
I moved messages from IMAP folders to new local folders.

Later, I renamed some of the local folders.

Then, when trying to access the local folders, some could not be reached (folders would not show any sub-folders and would show "???" in the "Size' column.

Invstigating through the file-system with Windows-Explorer, I found the folders and messages were present, but the path name was possibly too long for Thunderbird to navigate (folder-path 265 characters long).

From the Thunderbird folder list, I renamed some of the parent folders to shorter nanes so the file-system paths to all the sub-folders and messages was below 230 characters long.

After renaming the folders, all the sub-folders were reachable from the Thunderbird folder list, but the message-file and .msf file were no longer present. Thunderbird deleted these message-files/messages without warning or notification when Thunderbird renmed the folders.

This caused the loss of about message-files and over 100 megabytes of emails.

None of these message files or messages can be found in the Trash or in any other folders.

I believe Thunderbird should be able to handle long-path names, and that Thunderbird should not delete files and messages without prompting to allow the action.
(Reporter)

Comment 1

7 years ago
Please delete this duplicate report.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 752085
You need to log in before you can comment on or make changes to this bug.