After updating to Seamonkey 2.9.1, emails deleted from folder reappear

RESOLVED WORKSFORME

Status

SeaMonkey
General
RESOLVED WORKSFORME
6 years ago
6 years ago

People

(Reporter: mfgowombeck, Unassigned)

Tracking

SeaMonkey 2.9 Branch
x86_64
Windows 7

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:12.0) Gecko/20120429 Firefox/12.0 SeaMonkey/2.9.1
Build ID: 20120429011004

Steps to reproduce:

Deleted several emails, emptied trash, and compacted folders; 
Closed Seamonkey; 
later restarted Seamonkey and opened email.


Actual results:

The previously deleted emails reappeared.


Expected results:

Should not have reappeared.

Comment 1

6 years ago
POP or IMAP?

Were these emails downloaded anew?

What are your settings for "Leave messages on server"?
(Account Settings | Server Settings -> Leave messages ...)
(Reporter)

Comment 2

6 years ago
(In reply to therube from comment #1)
> POP or IMAP?
> 
> Were these emails downloaded anew?
> 
> What are your settings for "Leave messages on server"?
> (Account Settings | Server Settings -> Leave messages ...)

POP.  "Leave messages on server" is UNchecked.
As you'll note in bug title this didn't happen until UPgrading to 2.91.
Thanks for your interest.

Comment 3

6 years ago
Does this apply, Bug 751693 - Seamonkey 2.9.1 mail will not delete messages while downloading new mail from pop servers ?
(Reporter)

Comment 4

6 years ago
(In reply to therube from comment #3)
> Does this apply, Bug 751693 - Seamonkey 2.9.1 mail will not delete messages
> while downloading new mail from pop servers ?

No. I delete the items, compact folders, even walk away for hours or a day, items are back in box. This not happening during a download of new mail. When I check the email at the domain under my account, it does not exist because of not checking the "Leave mail on server" box. This repeats every time. I'm considering going back to 2.9.
(Reporter)

Comment 5

6 years ago
(In reply to mfgowombeck from comment #4)
> (In reply to therube from comment #3)
> > Does this apply, Bug 751693 - Seamonkey 2.9.1 mail will not delete messages
> > while downloading new mail from pop servers ?
> 
> No. I delete the items, compact folders, even walk away for hours or a day,
> items are back in box. This not happening during a download of new mail.
> When I check the email at the domain under my account, it does not exist
> because of not checking the "Leave mail on server" box. This repeats every
> time. I'm considering going back to 2.9.

I resolved this by backing up Mail and bookmarks and uninstalling 2.9.1 completely. Reinstalled Seamonkey 2.9.1 creating a new profile folder and then replacing Mail folder with backup. Email is now working normally.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.