Closed Bug 752177 Opened 8 years ago Closed 8 years ago

Forwarding message creates phantom nsmail.tmp attachment

Categories

(Thunderbird :: General, defect)

12 Branch
x86
Windows XP
defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 745919

People

(Reporter: classics, Unassigned)

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 5.1; rv:12.0) Gecko/20100101 Firefox/12.0
Build ID: 20120420145725

Steps to reproduce:

Thunderbird is generating a phantom "nsmail.txt" attachment titled "Attached Message Part" (22 bytes) when certain messages not containing attachments are forwarded.  This appears to be related to the headers, not the content of the message.  A minimal test case is attached.

What I did:

Create a message in an IMAP folder containing the minimal message text attached below.
Open message in Thunderbird.
Press 'Forward'

Using version 12.0.1 on Windows XP


Actual results:

Thunderbird generates a empty MIME attachment in the forwarded messages titled "Attached Message Part".  If sent, this creates a empty MIME attachment in the outgoing message.


Expected results:

Thunderbird should not recognize any MIME attachments in this message, they are not present.
> minimal.txt (Minimal test case message)

Simple text mail with no Content-Type: header. Dup of bug 745919.
I think :hiro is the expert on temp files.
Status: UNCONFIRMED → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 745919
You need to log in before you can comment on or make changes to this bug.