indication of grouped tabs seems to be missing

RESOLVED WONTFIX

Status

Firefox Graveyard
Panorama
RESOLVED WONTFIX
6 years ago
2 years ago

People

(Reporter: Rolf Leggewie, Unassigned)

Tracking

Details

(Reporter)

Description

6 years ago
I've just been made aware of tab grouping.  Looks like a very interesting feature.  One thing that I'm missing is a visual indicator if there are tabs hidden away in groups.  Let's say I have tab 1-3 open and visible in a window.  There are two further groups with 5 tabs among them that are hidden from view.  Now when I'm done with those three visible tabs I might think it's time to close the window, potentially missing the two hidden tab groups that I haven't dealt with, yet.

Updated

6 years ago
Component: Tabbed Browser → Panorama
QA Contact: tabbed.browser → panorama
This problem just happened to me, I've spent two weeks organizing a great division of tab groups, then, after closing a firefox window, my expectation would be that I would end on the panorama window, just like when you close the last tab of a group.

However, I lost all my groups instead.

Maybe this bug should receive a data-loss tag and maybe the ux tag, the actual behaviour is very very bad for a user that actually uses panorama.


Steps to reproduce:

- open the panorama window (Cmd+Shift+E)
- create a nice organization of groups
- open a group
- close the window

Expected results:

- the user is taken back to the panorama window to see if there might be important tabs in the other groups AND also for not lose the nice groups divisions he might have created

Actual results:

- the uses loses everything, all the tabs in other groups and his visual separations/organization of groups, group names, everything :(
Panorama has been removed from Firefox 45, currently in Beta and scheduled for release on March 7th. As such, I'm closing all existing Panorama bugs.

If you are still using Panorama, you will see a deprecation message in Firefox 44, and when 45 is released your tab group data will be migrated to bookmarks, with a folder for each group. There are also a few addons offering similar functionality.

See https://support.mozilla.org/en-US/kb/tab-groups-removal for more info.

We're removing Panorama because it has extremely low usage (about 0.01% of users), and has a large number of bugs and usability issues. The cost of fixing all those issues is far too high to justify, and so we'll instead be focusing our time and energy on improving other parts of Firefox.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WONTFIX
(Assignee)

Updated

2 years ago
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.