After contact deleted in any address book, focus unexpectedly shifts to first contact in Personal Address Book

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
7 years ago
5 months ago

People

(Reporter: edsat, Unassigned)

Tracking

12 Branch
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User Agent: Mozilla/5.0 (Windows NT 5.1; rv:12.0) Gecko/20100101 Firefox/12.0
Build ID: 20120420145725

Steps to reproduce:

Created address books A, B and C in additional to Personal Address Book.




Actual results:

Following deletion of any contact from any of the address books A, B or C the cursor does not remain in that book but rather switches to the first contact in the Personal Address book.


Expected results:

No exit from address book in use after deletion of a single contact.

Comment 1

7 years ago
(In reply to edsat from comment #0)
Works for me:
User Agent: Mozilla/5.0 (X11; Linux i686; rv:12.0) Gecko/20120428 Thunderbird/12.0.1
Application Build ID: 20120428123100

When I delete a contact, the cursor stays in that particular address book. No jump happens to the Personal address book.
(In reply to Hashem Masoud from comment #1)
> (In reply to edsat from comment #0)
> Works for me:
> When I delete a contact, the cursor stays in that particular address book.
> No jump happens to the Personal address book.

Let's avoid using misleading terminology: There is no *cursor* when deleting contacts from AB. Edsat (reporter) and Hashem, you mean indication of *focus* (dotted border)?

I agree with Hashem on Linux that reporter's scenario is wfm (on WinXP, TB12.0.1).

The only thing I see is some minor oddness when deleting *all* contacts from an AB:
- delete all contacts from custom AB
- right-click on blank contacts list (or press context Menu key on Windows keyboards)

Actual
- context menu for contact pops up, with most commands enabled (but there is no contact)

Expected
- don't show context menu for non-existing ui elements (no contacts here)
- if anything, we might show the context menu for the AB (but I'm not sure about delete command, because deleting AB from there doesn't feel right - ux-error-prevention - maybe delete AB command can be disabled in that situation)

Edsat, we cannot reproduce your problem. Do you have more details how to reproduce?

Can you reproduce this problem in Safe Mode?
https://support.mozillamessaging.com/kb/safe-mode
Summary: After contact deleted in any address book, cursor exits that book and positions to first contact in Personal Address Book. → After contact deleted in any address book, focus unexpectedly shifts to first contact in Personal Address Book
OT:

(In reply to Thomas D. from comment #2)
> The only thing I see is some minor oddness when deleting *all* contacts from
> an AB:
> Actual
> - context menu for contact pops up, with most commands enabled (but there is
> no contact)

- and no visual indication of focus

> Expected
> - don't show context menu for non-existing ui elements (no contacts here)
> - if anything, we might show the context menu for the AB (but I'm not sure
> about delete command, because deleting AB from there doesn't feel right -
> ux-error-prevention - maybe delete AB command can be disabled in that
> situation)

- when there are no contacts left after deleting the last contact, shift focus to current AB in AB list on the left

...which needs a new bug.

Comment 4

5 months ago
I cannot reproduce this using 60 beta
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 months ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.