Sync keeps losing config, claims wrong recovery key

RESOLVED DUPLICATE of bug 751950

Status

Cloud Services
Firefox Sync: Backend
--
major
RESOLVED DUPLICATE of bug 751950
6 years ago
6 years ago

People

(Reporter: gcp, Unassigned)

Tracking

({regression})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
Today, Desktop Firefox Sync suddenly claimed "Wrong Recovery Key" and told me to Reset / Update / Unlike device. I unliked - relinked and it appears to work.

Several hours later, the same problem happened again.

I had several crashes today due to a JS bug in Nightly. I do not know if the crashes are related to this problem, but I would expect the stored config to survive a crash.
(Reporter)

Comment 1

6 years ago
Actually, it seems to lose the Sync key at each restart.
(Reporter)

Comment 2

6 years ago
I seem to have this setting in user.js, not sure if related or how it got there:

user_pref("services.sync.deletePwd", true);

I enabled sync-ing of Preferences quite recently. The other Sync-ed PCs are a Beta desktop client and Android Nightly.
(Reporter)

Comment 3

6 years ago
This does not happen with Aurora on the same profile. It does not even get the Wrong Recovery Key message. So this is a regression in today's Nightly.
Severity: normal → major
Keywords: regression
(Reporter)

Comment 4

6 years ago
I see commits today for bug 751950 and bug 749957 which appear to touch relevant areas?
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 751950
Stored config persists, but an in-memory value doesn't get generated correctly until the first sync.

Please try with current m-c or tomorrow's nightly.
You need to log in before you can comment on or make changes to this bug.