Clicking Details Link on Firefox 3.6 update dialog links to Student reps

RESOLVED DUPLICATE of bug 752178

Status

www.mozilla.org
General
RESOLVED DUPLICATE of bug 752178
6 years ago
6 years ago

People

(Reporter: retornam, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

6 years ago
STR:

1) Download and install older version of Firefox like 3.6.17
2) Open Firefox and the Downloading Firefox 3.6.18 link under help
3) When the dialog opens, click on the details link
4)  Clicking on the link shows https://www.mozilla.com/en/404 which  incorrectly links to the student reps page.

See attached screencast for a better explanation
http://screencast.com/t/7E6tfrgn


Expected Results:
1) The details link should show the release notes page for the version of Firefox that is being downloaded.

Updated

6 years ago
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 752178
(Assignee)

Updated

6 years ago
Component: www.mozilla.org → General
Product: Websites → www.mozilla.org
You need to log in before you can comment on or make changes to this bug.