Website not displaying properly in Nightly builds (v13 onwards) - but displays correctly in Firefox (v11) stable build

RESOLVED DUPLICATE of bug 747617

Status

()

RESOLVED DUPLICATE of bug 747617
7 years ago
7 years ago

People

(Reporter: bhattaci, Unassigned)

Tracking

({regression})

13 Branch
x86
Windows 7
regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; rv:11.0) Gecko/20100101 Firefox/11.0
Build ID: 20120312181643

Steps to reproduce:

Visited

https://www.franklintempletonindia.com/india_app/Investors/login/inv_login_main.asp




Actual results:

The page comes up without the Username and password fields (including the virtual keyboard)


Expected results:

Opening with Firefox stable (v.11), and I as far as I remember even Nightly v.12 renders the page correctly.

Problem exists in both 64 bit and 32 bit (windows) versions of Nightly.

Comment 2

7 years ago
Confirmed on 
http://hg.mozilla.org/releases/mozilla-beta/rev/168f3814b32e
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:13.0) Gecko/20100101 Firefox/13.0 ID:20120501201020

And An error in error console as follows:
Error: TypeError: document.all is not a function
Source file: https://www.franklintempletonindia.com/india_app/Investors/login/inv_login_main.asp
Line: 55


Regression window(m-c)
works:
http://hg.mozilla.org/mozilla-central/rev/246bc1c98175
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:13.0) Gecko/20120221 Firefox/13.0a1 ID:20120221125718
fails:
http://hg.mozilla.org/mozilla-central/rev/9bde0d25d76e
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:13.0) Gecko/20120221 Firefox/13.0a1 ID:20120221131517
pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=246bc1c98175&tochange=9bde0d25d76e


Regression window(m-i)
works:
http://hg.mozilla.org/integration/mozilla-inbound/rev/a374a3bb0bc2
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:13.0a1) Gecko/13.0a1 Firefox/13.0a1 ID:20120220204554
fails:
http://hg.mozilla.org/integration/mozilla-inbound/rev/63861267f6a7
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:13.0a1) Gecko/13.0a1 Firefox/13.0a1 ID:20120220223057
pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=a374a3bb0bc2&tochange=63861267f6a7

Triggered by:
e6ffb760d2f0	Igor Bukanov — bug 726944 - Remove JSClass::xdrObject and related functionality. r=luke
Assignee: nobody → general
Blocks: 726944
Status: UNCONFIRMED → NEW
Component: Untriaged → JavaScript Engine
Depends on: 747617
Ever confirmed: true
Keywords: regression
Product: Firefox → Core
QA Contact: untriaged → general
Version: 15 Branch → 13 Branch
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 747617
You need to log in before you can comment on or make changes to this bug.