replying formats messages differently based on view method

VERIFIED DUPLICATE of bug 496405

Status

Thunderbird
General
VERIFIED DUPLICATE of bug 496405
6 years ago
6 years ago

People

(Reporter: Troy Sankey, Unassigned)

Tracking

12 Branch
x86_64
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:12.0) Gecko/20100101 Firefox/12.0
Build ID: 20120426131355

Steps to reproduce:

1. View -> Message Body As -> Original HTML
2. Hold down shift and reply to a message as plaintext (one that has at least two levels deep of responses)
(take a note of the formatting and close the window)
3. View -> Message Body As -> Plain Text
4. same as step 2



Actual results:

Step 2 yields this:

On 05/05/12 17:08, Bob Smith wrote:
> Hi John :)
> 
> On 05/05/12 14:28, John Doe wrote:
>     Some text some text some text some text some text some text some
>     text some text.
>
>     On 05/04/12 20:21, Bob Smith wrote:
>          Original message original message original message original message
>           original message original message original message.


Step 4 yields this:

On 05/05/12 17:08, Bob Smith wrote:
> Hi John :)
> 
> On 05/05/12 14:28, John Doe wrote:
>> Some text some text some text some text some text some text some
>> text some text.
>>
>> On 05/04/12 20:21, Bob Smith wrote:
>>> Original message original message original message original message
>>> original message original message original message.


Expected results:

Formatting of the response should not depend on how the user chooses to view email. It should be generated directly from the message source.

I suggest following the output from Step 4, since it is the standard.

Comment 1

6 years ago
(In reply to Troy Sankey from comment #0)
Duplicate of bug 496405.

Comment 2

6 years ago
(In reply to Hashem Masoud from comment #1)
> (In reply to Troy Sankey from comment #0)
> Duplicate of bug 496405.

Hashem, thank you for finding the duplicate!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 496405

Comment 3

6 years ago
...and Troy, thanks for reporting this!
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.