Ctrl+M doesn't bring up compose window in mail 3 pane

VERIFIED FIXED in mozilla0.9

Status

P2
normal
VERIFIED FIXED
18 years ago
14 years ago

People

(Reporter: scottputterman, Assigned: ssu0262)

Tracking

({access})

Trunk
mozilla0.9
access

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta1+])

Attachments

(2 attachments)

(Reporter)

Description

18 years ago
Using 2001040904 in Win NT.

I'm in the 3 pane.  I hit Ctrl+M.  Nothing happens.

Expected:  Message compose window comes up.

This works fine from the browser.
(Reporter)

Comment 1

18 years ago
marking nsbeta1+.  the toolbar button works fine.
Keywords: nsbeta1
Priority: -- → P2
Whiteboard: [nsbeta1+]
Target Milestone: --- → mozilla0.9
(Assignee)

Comment 2

18 years ago
Created attachment 30182 [details] [diff] [review]
patch attempt #1
Keywords: access
OS: Windows NT → All
Hardware: PC → All

Comment 3

18 years ago
The menuitem that invokes the compose window and the key should both have 
command="cmd_newMessage" on them, and no oncommand handlers.

Comment 4

18 years ago
Build 2001-04-09-04: NT4
When I tried this on my system Ctrl+M worked using the alt-3pane, but did not 
using the regular 3pane.
QA Contact: esther → nbaca
(Assignee)

Comment 5

18 years ago
Created attachment 30300 [details] [diff] [review]
patch attempt #2

Comment 6

18 years ago
Sean, looks good, but the `New Message' menuitem should be using the same 
command (one of the main points of a command is to use the same oncommand 
handler across many elements).  Or is the New Message item overlayed onto the 
window?  If that's the case, we don't really need the <command/> at all, and 
the oncommand handler can just go on the key (sorry for not clarifying earlier).

Comment 7

18 years ago
Blake,

When you say the same command, are you referring to "cmd_NewMessage" ? Sean's
patch does use it..right ? Let me know if I am missing something here..One thing
I noticed is that this command is missing from 'Message' menuitem's commandset
i.e., commandset id="mailMessageMenuItems".

bhuvan

(Reporter)

Comment 8

18 years ago
*** Bug 75937 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 9

18 years ago
This happens to have gotten fixed by the patch to bug 75038 and bug 75447 (the 
patch to messenger.xul).

Marking this fixed.
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED

Updated

18 years ago
Status: RESOLVED → VERIFIED

Comment 10

18 years ago
Build 2001-04-17-04: NT4, Mac 9.04
Build 2001-04-17-08: Linux RH 6.2
Verified Fixed.
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.