If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Check URL when getting thumbnails

VERIFIED FIXED in Firefox 14

Status

()

Firefox for Android
General
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: bnicholson, Assigned: bnicholson)

Tracking

unspecified
Firefox 15
ARM
Android
Points:
---

Firefox Tracking Flags

(firefox14 fixed, firefox15 verified, firefox16 verified, blocking-fennec1.0 +)

Details

Attachments

(1 attachment)

(Assignee)

Description

5 years ago
On document stop, we post a delayed (500ms) Runnable for getting a page's thumbnail. Pages can change in this interval, especially those that redirect, so we should make sure the document stop URL matches the tab URL.
(Assignee)

Comment 1

5 years ago
Created attachment 621753 [details] [diff] [review]
patch

Carried over from bug 752426.
Attachment #621753 - Flags: review?(blassey.bugs)
Attachment #621753 - Flags: review?(blassey.bugs) → review+
(Assignee)

Comment 2

5 years ago
http://hg.mozilla.org/integration/mozilla-inbound/rev/6c0ad67ab495

Comment 3

5 years ago
https://hg.mozilla.org/mozilla-central/rev/6c0ad67ab495
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 15
(Assignee)

Comment 4

5 years ago
Comment on attachment 621753 [details] [diff] [review]
patch

[Approval Request Comment]
Regression caused by (bug #): 
User impact if declined: thumbnails may be associated with wrong page
Testing completed (on m-c, etc.): m-c
Risk to taking this patch (and alternatives if risky): low risk
String changes made by this patch: none
Attachment #621753 - Flags: approval-mozilla-aurora?

Comment 5

5 years ago
We are leaving all non-beta+ bugs nominated for Aurora approval in the queue until FN14 Beta 1 is signed off on by QA.

Updated

5 years ago
blocking-fennec1.0: --- → ?
blocking-fennec1.0: ? → +
Attachment #621753 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+

Updated

5 years ago
status-firefox14: --- → affected
(Assignee)

Comment 6

5 years ago
http://hg.mozilla.org/releases/mozilla-aurora/rev/7e10c8d85def

Updated

5 years ago
status-firefox14: affected → fixed

Comment 7

5 years ago
Verified/Fixed on:
Nightly Fennec 16.0a1 (2012-06-20)
Aurora Fennec 15.0a2 (2012-06-20)
Device: HTC Desire Z
OS: Android 2.3.3
Status: RESOLVED → VERIFIED
status-firefox15: --- → verified
status-firefox16: --- → verified
You need to log in before you can comment on or make changes to this bug.