If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Exception 0x80550013 [nsIMsgFolder.subFolders] location: "JS frame :: resource:///modules/MailUtils.js :: MailUtils_discoverFolders :: line 77" (Once a localized Tb 12.0.1 build is used, this exception is reported for each POP3 account upon each restart)

RESOLVED DUPLICATE of bug 759237

Status

MailNews Core
Backend
RESOLVED DUPLICATE of bug 759237
6 years ago
5 years ago

People

(Reporter: World, Assigned: hiro)

Tracking

x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
Build : Tb 12.0.1 release build.
Same in Tb 12.0.1 ja & Tb 12.0.1 de.

Once a localized Tb 12.0.1 build is used and localized special folder name is shown at folder pane, following error is always reported at Error Console for each POP3 account when Tb 12.0.1(any localization) is restarted using same Tb's profile.
> Discovering folders for account failed with exception: [Exception...
> "Component returned failure code: 0x80550013 [nsIMsgFolder.subFolders]"  nsresult: "0x80550013 (<unknown>)"
> location: "JS frame :: resource:///modules/MailUtils.js :: MailUtils_discoverFolders :: line 77"  data: no]

I couldn't observe error in message filter execution even though this Exception was reported. But this kind of exception shouldn't occur.

[Steps to reproduce]
(1) Use a Tb's profile(call ProfX) by Tb 11.0.1 en-US, in order to to bypass
    problem of bug 752423.
    Use View/Folders/Unified once and back to View/Folders/All, to avoid
    unwanted error messages related to smart folders.
    All special folders are shown in English name.
    No need to define message filter.
    Terminate Tb 11.0.1 en-US build.
(2) Start localized Tb 12.0.1 using ProfX. (checked with de & ja build)
    All special folders are shown as localized special folder name.
    Terminate Tb.
(3) Restart Tb 12.0.1 of same localization using same ProfX.
    Above exception is reported for each POP3 account upon any restart.  
(4) Restart Tb 12.0.1 of same or different localization using same ProfX.
    (checked with en-US, de, ja build)
    Above exception is reported for each POP3 account upon any restart.

Root cause seems "localized folder name is written in .msf file by Tb 12".
(Reporter)

Updated

6 years ago
Depends on: 752423
(Reporter)

Updated

6 years ago
Component: Filters → Backend
QA Contact: filters → backend
I could confirm the fix for bug 752423 does also fix this issue.
No longer depends on: 752423
Oops! Accidentally removed dependency.
Depends on: 752423
Created attachment 625536 [details] [diff] [review]
Proposed fix

I'd suggest that try catch statements should be removed there.
Assignee: nobody → hiikezoe
Status: NEW → ASSIGNED
Attachment #625536 - Flags: review?(dbienvenu)

Comment 4

5 years ago
Comment on attachment 625536 [details] [diff] [review]
Proposed fix

There are lots of ways getsubfolders can throw an exception, so I think we should leave the catch and logging in, and just mark this bug as a dup of the bug where you have a fix for this particular exception. If I'm misunderstanding something, please let me know...
Attachment #625536 - Flags: review?(dbienvenu) → review-

Comment 5

5 years ago
Is there any relation to bug 751562 here?
(In reply to :aceman from comment #5)
> Is there any relation to bug 751562 here?

I don't think so.
(In reply to David :Bienvenu from comment #4)
> Comment on attachment 625536 [details] [diff] [review]
> Proposed fix
> 
> There are lots of ways getsubfolders can throw an exception, so I think we
> should leave the catch and logging in, and just mark this bug as a dup of
> the bug where you have a fix for this particular exception. If I'm
> misunderstanding something, please let me know...

which bug is that?

ref: https://getsatisfaction.com/mozilla_messaging/topics/upgrade_to_13_0_1_breaks_my_folders

Comment 8

5 years ago
(In reply to Wayne Mery (:wsmwk) from comment #7)

> > There are lots of ways getsubfolders can throw an exception, so I think we
> > should leave the catch and logging in, and just mark this bug as a dup of
> > the bug where you have a fix for this particular exception. If I'm
> > misunderstanding something, please let me know...
> 
> which bug is that?

 bug 752423
so this should be fixed in v13
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 759237
bienvenu, Do you think https://getsatisfaction.com/mozilla_messaging/topics/
> upgrade_to_13_0_1_breaks_my_folders is a different issue?

Comment 11

5 years ago
(In reply to Wayne Mery (:wsmwk) from comment #10)
> bienvenu, Do you think https://getsatisfaction.com/mozilla_messaging/topics/
> > upgrade_to_13_0_1_breaks_my_folders is a different issue?

It's the same error code, NS_MSG_FOLDER_EXISTS. I didn't think we could still return that error code, but there must be some path that does.
You need to log in before you can comment on or make changes to this bug.