Last Comment Bug 752737 - Delete the default/copy constructors and assignment operator from JSString, JSObject
: Delete the default/copy constructors and assignment operator from JSString, J...
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: Trunk
: All All
: -- minor (vote)
: mozilla15
Assigned To: Jeff Walden [:Waldo] (remove +bmo to email)
:
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-07 16:27 PDT by Jeff Walden [:Waldo] (remove +bmo to email)
Modified: 2012-05-08 03:23 PDT (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch (5.20 KB, patch)
2012-05-07 16:27 PDT, Jeff Walden [:Waldo] (remove +bmo to email)
luke: review+
Details | Diff | Splinter Review

Description Jeff Walden [:Waldo] (remove +bmo to email) 2012-05-07 16:27:10 PDT
Created attachment 621777 [details] [diff] [review]
Patch

Now that NewObjectCache doesn't embed a JSObject_Slots16 instance that needs a constructor on JSObject, this is easy for that case.  JSString is nearly as easy, just one test to fix up (in the manner that test's object-inspecting code already does).

Note that because these deletions inherit, we can get rid of deletions in all subclasses and still get errors on misuse.  Derived classes could implement these bits, to be sure, but that requires enough effort that I'm not too worried about it.  And any documentation value in having these redundantly in derived classes seems negligible -- best just to not have them.
Comment 1 Luke Wagner [:luke] 2012-05-07 16:31:09 PDT
Comment on attachment 621777 [details] [diff] [review]
Patch

Yes, please.
Comment 2 Jeff Walden [:Waldo] (remove +bmo to email) 2012-05-07 19:28:54 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/e5f63aa66be6
Comment 3 Ed Morley [:emorley] 2012-05-08 03:23:50 PDT
https://hg.mozilla.org/mozilla-central/rev/e5f63aa66be6

Note You need to log in before you can comment on or make changes to this bug.