org/mozilla/gecko/sqlite/SQLiteBridge;.sqliteCallWithDb() crashes with "received null jstring" error

RESOLVED WORKSFORME

Status

()

Firefox for Android
Data Providers
--
critical
RESOLVED WORKSFORME
6 years ago
2 years ago

People

(Reporter: cpeterson, Unassigned)

Tracking

(Depends on: 1 bug, {crash})

unspecified
ARM
Android
crash
Points:
---

Firefox Tracking Flags

(firefox14 affected, firefox15 affected, firefox20 affected, firefox23-, firefox32 affected)

Details

(Whiteboard: [native-crash])

Attachments

(2 attachments)

(Reporter)

Description

6 years ago
Created attachment 621835 [details]
sqliteCallWithDb-null-jstring-crash.log

Nightly crashes on my Galaxy Nexus fairly often when I launch it. Here is an excerpt from my logcat. See the attached log for more info, including some Sync error messages and StrictMode violations.


D/GeckoPasswordsProvider( 7944): Successfully created database helper for profile: default
D/GeckoPasswordsProvider( 7944): No profile provided, using default
D/GeckoPasswordsProvider( 7944): Using path: /data/data/org.mozilla.fennec/files/mozilla/bx9mu8ke.default
D/GeckoPasswordsProvider( 7944): Successfully created database helper for profile: default
D/GeckoPasswordsProvider( 7944): No profile provided, using default
D/GeckoPasswordsProvider( 7944): Using path: /data/data/org.mozilla.fennec/files/mozilla/bx9mu8ke.default
D/GeckoPasswordsProvider( 7944): Successfully created database helper for profile: default
W/dalvikvm( 7944): JNI WARNING: received null jstring
W/dalvikvm( 7944):              in Lorg/mozilla/gecko/sqlite/SQLiteBridge;.sqliteCallWithDb:(JLjava/lang/String;[Ljava/lang/String;[J)Lorg/mozilla/gecko/sqlite/MatrixBlobCursor; (GetStringUTFChars)
E/dalvikvm( 7944): VM aborting
F/libc    ( 7944): Fatal signal 11 (SIGSEGV) at 0xdeadd00d (code=1)
I/DEBUG   (  116): *** *** *** *** *** *** *** *** *** *** *** *** *** *** *** ***
I/DEBUG   (  116): Build fingerprint: 'google/yakju/maguro:4.0.4/IMM76I/330937:user/release-keys'
I/DEBUG   (  116): pid: 7944, tid: 7959  >>> org.mozilla.f3nn3c.PasswordsProvider <<<
I/DEBUG   (  116): signal 11 (SIGSEGV), code 1 (SEGV_MAPERR), fault addr deadd00d

Updated

6 years ago
Severity: normal → critical
Keywords: crash
Whiteboard: [native-crash]
(Reporter)

Comment 1

6 years ago
I hit this crash (with Nightly 15) on my Galaxy Nexus about every 10-60 seconds. Neither Aurora 14 nor my private builds of m-c 15 crash, so something about my Nightly profile data must be hosed.
Cc'ing :wesj who wrote the relevant code.
(Reporter)

Comment 3

6 years ago
wesj, this PasswordsProvider exception consistently crashes Nightly on my Galaxy Nexus every 1-3 minutes. It is very annoying. I suspect my profile has some bogus password data stored in my PasswordsProvider, but Fennec should not be crashing.
status-firefox14: --- → affected
status-firefox15: --- → affected
Depends on: 745384

Comment 4

5 years ago
I just updated my phone from Gingerbread to Jellybean+ and started hitting this crash. It appears to happen when you have password entries without a user name. Looking through my list of saved passwords this seem to happen on a number of sites. I have created a small test page [1] that will allow you to easily create an entry that will trigger the crash. I have tested this using beta, aurora, and nightly and they all crash.

[1] http://isager.net/synctest.html
I suspect this needs the patch in bug 745384. Unfortunately, it makes our testing machines very angry. I'll try to dig into it again. Thanks.
Wes, any movement on this? Apparently this is still very much a thing.
status-firefox20: --- → affected
tracking-firefox23: --- → ?
This may still be a 'thing' but it's been around since 15 and unless it's in the topcrash list for Fennec, it's not a candidate for release tracking in FF23 - please re-nom if the volume (in FF23) changes for the worse.
tracking-firefox23: ? → -
CCing margaret and sola: might run into this when using the SQLiteBridge for content providers.

Comment 9

4 years ago
Created attachment 8384125 [details]
logcat.log

i have a similar crash. pleas help, i really want to use firefox…
(In reply to flying sheep from comment #9)

> i have a similar crash. pleas help, i really want to use firefox…

You're seeing Bug 966143, not this bug.

If you're using Master Password, consider turning it off, see if it fixes your issue.
Duplicate of this bug: 1081841
status-firefox32: --- → affected
Component: General → Data Providers
I'm getting this issue: https://etherpad.mozilla.org/1sIojsYzVa

Running dev build on Android M - N6
If you can reproduce it reliably and trace where the nulls are actually coming from that would be great. We've been unable to fix this in the past.
Flags: needinfo?(mhaigh)
Perhaps fixed by Bug 1135281.
I can no longer reproduce
Flags: needinfo?(mhaigh)
Let's call this done.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.