The default bug view has changed. See this FAQ.

--enable-system-{sqlite,nss,nspr} results in make -C browser/installer failing

RESOLVED FIXED in Firefox 16

Status

()

Firefox
Build Config
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: Andrew Benton, Assigned: Andrew Benton)

Tracking

Trunk
Firefox 16
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments, 1 obsolete attachment)

(Assignee)

Description

5 years ago
Created attachment 621965 [details] [diff] [review]
Patch to put an #ifndef MOZ_NATIVE_SQLITE in package-manifest.in

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:15.0) Gecko/15.0 Firefox/15.0a1
Build ID: 20120508010020

Steps to reproduce:

Added  --enable-system-sqlite to my mozconfig
ac_add_options --enable-system-sqlite
then when the build had finished I tried to
make -C browser/installer


Actual results:

Error: package error or possible missing or unnecessary file: bin/libmozsqlite3.so 
.....
make[1]: *** [stage-package] Error 255
make[1]: Leaving directory `/home/andy/save/src/firefox/firefox-build-dir/browser/installer'
make: *** [default] Error 2
make: Leaving directory `/home/andy/save/src/firefox/firefox-build-dir/browser/installer'



Expected results:

It should have made a nice new firefox tarball.
The attached patch fixes the problem for me.
(Assignee)

Comment 1

5 years ago
Created attachment 631763 [details] [diff] [review]
Added nspr and nss into the patch

--with-system-nspr and --with-system-nss also cause the installer to fail so I've added them into the patch
You mentioned in Bug 763181 that no-one responded, so I peeked and I see why (not your fault)

#1 Was filed in Untriaged and our triage team didn't get to it, moved it to its correct component
#2 No-one was requested for review of the patch (see the Getting Reviews part of https://developer.mozilla.org/En/Developer_Guide/How_to_Submit_a_Patch )

I'll leave you to request since I don't know how well you tested these changes, a good reviewer here would be :khuey or :glandium imo.
Status: UNCONFIRMED → NEW
Component: Untriaged → Build Config
Ever confirmed: true
QA Contact: untriaged → build.config
Summary: --enable-system-sqlite results in make -C browser/installer failing → --enable-system-{sqlite,nss,nspr} results in make -C browser/installer failing

Updated

5 years ago
Attachment #621965 - Attachment is patch: true

Updated

5 years ago
Attachment #631763 - Attachment is patch: true
(Assignee)

Updated

5 years ago
Attachment #631763 - Flags: review?(mh+mozilla)
Attachment #631763 - Flags: review?(khuey)
Comment on attachment 631763 [details] [diff] [review]
Added nspr and nss into the patch

Review of attachment 631763 [details] [diff] [review]:
-----------------------------------------------------------------

::: browser/installer/package-manifest.in
@@ +595,4 @@
>  @BINPATH@/@DLL_PREFIX@smime3@DLL_SUFFIX@
>  @BINPATH@/@DLL_PREFIX@softokn3@DLL_SUFFIX@
>  @BINPATH@/@DLL_PREFIX@ssl3@DLL_SUFFIX@
> +#endif

The #ifndef for this #endif is missing. Other than that, the patch looks good.
Attachment #631763 - Flags: review?(mh+mozilla)
Attachment #631763 - Flags: review?(khuey)
Attachment #631763 - Flags: review+
(Assignee)

Comment 4

5 years ago
Created attachment 631900 [details] [diff] [review]
added a missing #ifndef MOZ_NATIVE_NSS into the patch

(In reply to Mike Hommey [:glandium] from comment #3)
> Comment on attachment 631763 [details] [diff] [review]
> ::: browser/installer/package-manifest.in
> @@ +595,4 @@
> >  @BINPATH@/@DLL_PREFIX@smime3@DLL_SUFFIX@
> >  @BINPATH@/@DLL_PREFIX@softokn3@DLL_SUFFIX@
> >  @BINPATH@/@DLL_PREFIX@ssl3@DLL_SUFFIX@
> > +#endif
> 
> The #ifndef for this #endif is missing. Other than that, the patch looks
> good.

Many thanks, sorry for the missing #ifndef MOZ_NATIVE_NSS
Fixed in this version
Attachment #631763 - Attachment is obsolete: true
Attachment #631900 - Flags: review?(mh+mozilla)
Comment on attachment 631900 [details] [diff] [review]
added a missing #ifndef MOZ_NATIVE_NSS into the patch

Thanks for the patch. I'll land this alongside my next push (maybe some time tomorrow).

For your future patches, please follow the guidelines from https://developer.mozilla.org/en/Creating_a_patch_that_can_be_checked_in
Attachment #631900 - Flags: review?(mh+mozilla) → review+
https://hg.mozilla.org/integration/mozilla-inbound/rev/ede54971747f
Target Milestone: --- → Firefox 16
https://hg.mozilla.org/mozilla-central/rev/ede54971747f
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Assignee: nobody → b3nton
You need to log in before you can comment on or make changes to this bug.