After sync, visiting synced tabs, Facebook takes me to their Indonesian site

RESOLVED WORKSFORME

Status

Tech Evangelism
Mobile
RESOLVED WORKSFORME
6 years ago
5 years ago

People

(Reporter: Carmen, Unassigned)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [Engagement] [User Engagement])

(Reporter)

Description

6 years ago
Web page or screen you were on when you saw the issue: 

Steps to reproduce:
1. Downloaded latest Aurora onto my Samsung
2. Performed a Sync with my Firefox Desktop on my MacBook Air
3. At first, Sync gave an error message : Sync not responding, will be back soon
4. Re-synced
5. Opened a tab, navigated to Synched Tabs
6. Clicked on the Facebook tab
7. Facebook opened a m.facebook.com page in Indonesian (My Samsung is set to English, all other sites open in English.) Full url http://m.facebook.com/?refscrc=http%3A%2F%2Fwww.facebook.com%2F&_rdr
8. Navigated to www.Facebook.com using the url bar (not a Synced tab or a Top Site)
9. Still takes me to the Indonesian page
10. Native browser seems to do the same thing, however. 



What you expected: I expected to get the EN Facebook site, since I browse in EN

Crash report ID (if applicable): NA
(Reporter)

Updated

6 years ago
Summary: After sync, visiting synced tabs, Facebook takes me to their German site → After sync, visiting synced tabs, Facebook takes me to their Indonesian site
Tracy - Any ideas? Also, where does this bug belong (product/component)?
Sync doesn't change URLs.  Seem to me to be Facebook redirecting for some reason.

What did Facebook do on the Samsung before Sync was enabled?
Carmen, please check what the URL address is of the tab you have open on Desktop Firefox that you think got Synced over
(Reporter)

Comment 4

6 years ago
Honestly, I'm not normally an Android user, so the first time I went to Facebook on the Samsung Galaxy Nexus was from a Synced Tab. I don't have a scenario prior to Sync, because I just started using it today for testing purposes.

The url for my Facebook tab that's synced from the Desktop is: https://www.facebook.com/ - and I'm in a logged-in state.
It's a facebook preference saving the language for your login.  I tested it out with Japanese.  Facebook does their own localization for various languages afaik.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → INVALID
That would imply that Carmen had set the language for Facebook? Is that something you might have at some point done Carmen? Doesn't sound like it.
(Reporter)

Comment 7

6 years ago
No - I did not set my language for Facebook. This was the first time I had ever opened Facebook on the Android (I'm only using it for testing.) Everything else on my browser is in EN, my phone language is set to EN, etc.
Status: RESOLVED → REOPENED
Resolution: INVALID → ---
(Reporter)

Comment 8

6 years ago
If it helps, the same thing happened in Beta build - AFTER I had switched in Aurora to the EN version of Facebook.
Facebook recently pushed some updates. Can you still reproduce this issue?
(In reply to Lawrence Mandel [:lmandel] from comment #9)
> Facebook recently pushed some updates. Can you still reproduce this issue?

I can't reproduce. comment 0 seems to imply that this isn't a FF Android evangelism problem, as the problem happens on stock as well.

Updated

6 years ago
Component: Evangelism → Mobile
OS: Mac OS X → Android
Product: Firefox for Android → Tech Evangelism
Hardware: x86 → ARM
Version: Trunk → unspecified

Comment 11

5 years ago
Can we close as works for me?
(In reply to Chris Lee [:clee] from comment #11)
> Can we close as works for me?

Yeah let's do that.
Status: REOPENED → RESOLVED
Last Resolved: 6 years ago5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.