Last Comment Bug 753000 - Windows 7 (32 & 64 bit) unit test builders have inconsistent display resolution to other windows builders and to the set-up scripts
: Windows 7 (32 & 64 bit) unit test builders have inconsistent display resoluti...
Status: RESOLVED FIXED
:
Product: Thunderbird
Classification: Client Software
Component: Testing Infrastructure (show other bugs)
: Trunk
: All All
: -- major (vote)
: Thunderbird 16.0
Assigned To: Mark Banner (:standard8)
:
Mentors:
Depends on:
Blocks: 750461
  Show dependency treegraph
 
Reported: 2012-05-08 11:09 PDT by Mark Banner (:standard8)
Modified: 2012-07-03 08:32 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
The fix (1.54 KB, patch)
2012-06-28 11:28 PDT, Mark Banner (:standard8)
irving: review+
Details | Diff | Review

Description Mark Banner (:standard8) 2012-05-08 11:09:03 PDT
According to

http://hg.mozilla.org/build/puppet-manifests/annotate/a2a258487085/modules/buildslave/files/startTalos-w7.bat#l10
http://hg.mozilla.org/build/puppet-manifests/annotate/a2a258487085/modules/buildslave/files/startTalos-w764.bat#l11

the builders are meant to have 1280 x 1024 resolution.

However, on the Thunderbird comm-central builders we're seeing MozMill test failures that are typically a result of having the screen resolution set wrong (we require 1280x1024).

According to bhearsum, talos-r3-w7-066 and t-r3-w764-003 appear to be on a 800 x 600 resolution, or maybe a 1024 x 768.

Hence it looks like the configuration hasn't been applied.
Comment 1 Ben Hearsum (:bhearsum) 2012-05-08 13:25:03 PDT
Armen, any idea about this?
Comment 2 Armen Zambrano [:armenzg] - Engineering productivity 2012-05-08 14:58:03 PDT
At some point we upgraded the stock drivers which caused a regression on the available screen resolutions.

The only way to fix this is by attaching a dongle to the machine.

I still have to test the path out of this situation.
My ideal solution is:
1) replace those start scripts to set a 800x600 resolution (make sure no regressions are caused)
2) take down slaves and attach dongles (the screen resolution should still be 800x600 because of #1)
3) find a way to control screen resolution by code; this way we can control it by branch

If we could do #3 directly we would not need #2 & #1. I think.

Unfortunately, even the mouse pointer and focus gets on the way depending on the screen resolution.

You can read for more context from here on:
https://bugzilla.mozilla.org/show_bug.cgi?id=712630#c74

What should we do to this bug? Block it on bug 712630? or mark it as a dupe?
Comment 3 Mark Banner (:standard8) 2012-05-09 02:00:26 PDT
(In reply to Armen Zambrano G. [:armenzg] - Release Engineer from comment #2)
> What should we do to this bug? Block it on bug 712630? or mark it as a dupe?

I'm happy with either. If we dupe it, then I think we should re-title that bug and move it to releng, as that seems to be where the work is currently.
Comment 4 Chris Cooper [:coop] 2012-05-17 14:11:21 PDT

*** This bug has been marked as a duplicate of bug 712630 ***
Comment 5 Mark Banner (:standard8) 2012-06-28 11:06:41 PDT
Ok, now bug 712630 has landed, I'm going to use this bug to do the necessary work in Thunderbird land to get the screen resolution right for us.
Comment 6 Mark Banner (:standard8) 2012-06-28 11:28:15 PDT
Created attachment 637612 [details] [diff] [review]
The fix

The MozMill tests (test-display-issues.js) have required a screen resolution of 1280 x 1024. When we moved to the Firefox infrastructure the Windows 7 builders were set on 1024 x 768 and the Windows XP ones on 1280 x 1024.

Due to this, the Windows 7 MozMill builders have been on permanent orange since we moved to the new infra.

This patch takes the work one in bug 712630 and applies it to us - to use 1280 x 1024 on our builders. It also adds a couple of comments to test-display-issues.js so that it reminds us better (we've discussed in the past about detecting the screen res, but iirc we don't have the tools easily available in mozmill tests, and that would be a separate bug anyway ;-) ).

As you can't test the patch locally, I've already had this on try server, you can see the results here:

https://tbpl.mozilla.org/?tree=Thunderbird-Try&noignore=1&rev=56649865b138

(the noignore=1 is so you can see the currently hidden builders)
Comment 7 :Irving Reid (No longer working on Firefox) 2012-07-03 08:14:39 PDT
Comment on attachment 637612 [details] [diff] [review]
The fix

Review of attachment 637612 [details] [diff] [review]:
-----------------------------------------------------------------

Try build looks good, change looks good.
Comment 8 Mark Banner (:standard8) 2012-07-03 08:32:42 PDT
Checked in: https://hg.mozilla.org/comm-central/rev/eac86a1b54c5

Note You need to log in before you can comment on or make changes to this bug.