SeaMonkey crash with 80+ windows open due to NVIDIA drivers

RESOLVED INVALID

Status

SeaMonkey
General
--
critical
RESOLVED INVALID
6 years ago
3 years ago

People

(Reporter: Alexandre Desnoyers, Unassigned)

Tracking

({crash})

SeaMonkey 2.9 Branch
x86_64
Windows 7
crash

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [cause:NVIDIA drivers], crash signature)

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:12.0) Gecko/20120429 Firefox/12.0 SeaMonkey/2.9.1
Build ID: 20120429011004

Steps to reproduce:

To reproduce the problem: 
1) Set Seamonkey preference to open a new window when pressing CTRL+N (not tested with new tab option) 
2) Set you homepage to www.google.ca (no account login or any other google service enabled) 
3) Press CTRL+N until you have >100 windows open. Mozilla will stop responding for 1-2 minute until it crash.  No need to wait for each webpage to load, just fill-up your taskbar in Windows.  FYI, it's about three row in the taskbar at 1920x1200.

I've experienced this problem 3-4 times already with similar loads (80+ windows open, various website) using Seamonkey 2.6.1, 2.8 and now 2.9.1.   This problem can be reproduced under SeaMonkey 2.9.1 running on Win7 64bit 4Gig RAM and also under 2.6.1 running on WinXP 32bit with approx 3Gig RAM.
Already disabled all the extensions but do not fix the problem.


Actual results:

SeaMonkey crashed, see bug UUID 0fd8122c-6244-4a45-b83e-f9bad2120505


Expected results:

Should just work until there is no more RAM+swap
Probably a OOM crash. The crash report itself is unusable.
(Reporter)

Comment 2

6 years ago
Created attachment 623456 [details]
2.9.1 Local Build with debug, crash screenshot

Compiled the 2.9.1 source code today with debugging enabled.  This is my first attempt at starting the resulting EXE and re-creating the error.

FYI:  .mozconfig

ac_add_options --enable-application=suite
mk_add_options MOZ_OBJDIR=@TOPSRCDIR@/objdir-sm-debug
ac_add_options --enable-debug
ac_add_options --disable-optimize
mk_add_options MOZ_MAKE_FLAGS="-j4"

If you have suggestions on how to debug such error, please let me know.  Clicking on "Retry" just closed the application without starting the debugger.

I haven't looked at the source file pointed by the error yet... It's getting late here.... And probably someone will have a better idea of the problem than me.

Regards, 
Alex
That is an assertion and that doesn't lead to a crash in an optimized build.

Comment 4

3 years ago
Alexandre, do you still crash?
Severity: normal → critical
Flags: needinfo?(alex)
Keywords: crash
Whiteboard: [closeme 2015-02-12]
(Reporter)

Comment 5

3 years ago
Yes, and it is more present in the latest Seamonkey versions which are barely usable for me.  I tried to upgrade my prehistoric Seamonkey 2.12 (or was it 2.13?) to the last official release this Christmas, but it crashed _very_ often, I am talking about 1-4 times per day.  I submitted the crash reports trough the automatic report tool.

I suspect that something is using WAY too much memory in the newer releases.

I went back to Seamonkey 2.17.1 and this one work without any problems.

Let me know it I can help you.
Flags: needinfo?(alex)

Comment 6

3 years ago
please post your crash IDs
Flags: needinfo?(alex)
(Reporter)

Comment 7

3 years ago
Here you go, and this was with 5-10 windows open...

http://crash-stats.mozilla.com/report/index/bp-5dfb2871-3c1b-41b1-a19c-3fe332141229
http://crash-stats.mozilla.com/report/index/0c4d3a2b-098c-459d-8608-ae3e22141229
http://crash-stats.mozilla.com/report/index/bp-fee6e757-337a-4294-a258-083542141228
http://crash-stats.mozilla.com/report/index/bp-dcbd8a04-89c7-4857-8d14-1eba72141225
Flags: needinfo?(alex)

Comment 8

3 years ago
(In reply to Alexandre Desnoyers from comment #7)
> Here you go, and this was with 5-10 windows open...
> 
> http://crash-stats.mozilla.com/report/index/bp-5dfb2871-3c1b-41b1-a19c-
> 3fe332141229
> http://crash-stats.mozilla.com/report/index/0c4d3a2b-098c-459d-8608-
> ae3e22141229

Nvwgf2um.dll is part of NVIDIA D3D10 drivers

> http://crash-stats.mozilla.com/report/index/bp-fee6e757-337a-4294-a258-
> 083542141228

- points to LDDM User Mode Driver for Intel(R) Graphics Technology
- only 300MB vritual vree

> http://crash-stats.mozilla.com/report/index/bp-dcbd8a04-89c7-4857-8d14-
> 1eba72141225

one bug cited is https://bugzilla.mozilla.org/show_bug.cgi?id=1092810

300MB free of a 4gb  process is OOM or close to it. But OOM does not normally present as crashes in video drivers. So I suggest :
1. to run 80+ tabs on a 64bit OS like win7 you want to be using 64bit seamonkey builds, and on a 32bit XP you want to be using the /3GB switch of the OS (google for the info)
2. update your video drivers
3. if that doesn't help, disable video hardware assist in preferences
Whiteboard: [closeme 2015-02-12]
(Reporter)

Comment 9

3 years ago
I will try all of this when I back to Europe on Sunday.  I am in a conference in Silicon Valley at the moment...

Thank you very much.
(Reporter)

Comment 10

3 years ago
On Monday I finally updated the NVidia drivers and then Seamonkey to 2.32.  

I've only crashed once this week because of some stack corruption that ended in Visual Studio assembly viewer/debugger.  Seamonkey didn't offer the option to submit a crash report and it's not listed in the "about:crashes".

This setup seems much more stable than before.  Thanks a lot for the idea of updating the video drivers.

Comment 11

3 years ago
Thanks for the info
Status: UNCONFIRMED → RESOLVED
Crash Signature: [@ nvwgf2um.dll@0x296dc4 ]
Last Resolved: 3 years ago
Resolution: --- → INVALID
Summary: SeaMonkey crash with 80+ windows open → SeaMonkey crash with 80+ windows open due to NVIDIA drivers
Whiteboard: [cause:NVIDIA drivers]
You need to log in before you can comment on or make changes to this bug.