local-name and name returns wrong value for some nodetypes

VERIFIED FIXED

Status

()

Core
XSLT
VERIFIED FIXED
17 years ago
17 years ago

People

(Reporter: sicking, Assigned: sicking)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

The local-name and name functions return the wrong values for some nodetypes, 
only attributes, elements and processing instructions should return values !=""

patch coming up
Status: NEW → ASSIGNED
Keywords: review
Previously, all paths through this code resulted in |name| being processed by
the XMLUtils call, but now there are cases where you just break out of it
without doing anything to |name|.  Will that cause problems?
No that is intended behaviour. For those nodetypes the function should return 
empty string.

Comment 6

17 years ago
fix checked in, Axel
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 7

17 years ago
bitching buttons, verfication spam
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.