Illegal characters should not be copied in the Web Console

RESOLVED WONTFIX

Status

()

Firefox
Developer Tools: Console
RESOLVED WONTFIX
6 years ago
6 years ago

People

(Reporter: AlexLakatos, Unassigned)

Tracking

15 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
Created attachment 622344 [details]
reduced test case

Copying code from a web page that uses ” instead of ", into the Web Console, will copy it. When trying to run that code, you will get a SyntaxError: illegal character. The visual difference is slight, hence you will most likely debug your code for nothing.

Steps to Reproduce:
1.Open the reduced testcase attached to this bug
2.Open the Web Console
3.Copy the text from the page to the Web Console
4.Press Enter

Expected results:
3.The quote generated by ” is replaced with "
0r: 4.You get the result undefined

Actual results:
4.You get a SyntaxError: illegal character

Note: This happens as well for the Scratchpad. Is there a need for a new bug?
Then how can I test a code such as alert(escape('”'))?

Comment 2

6 years ago
” and " are not the same characters and I don't think we should magically swap them. It may be the case that there are code samples out there with "fancy quotes" because of overzealous wordpress plugins, but I don't think we want our tools to compensate for code that has been mangled.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.