Testcase that does a lot of reloading makes it difficult to open new links

RESOLVED WONTFIX

Status

()

P5
normal
RESOLVED WONTFIX
7 years ago
a year ago

People

(Reporter: martijn.martijn, Assigned: gbrown)

Tracking

({perf, testcase})

Trunk
ARM
Android
perf, testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

7 years ago
Steps to reproduce:
1 - Open http://people.mozilla.com/~mwargers/tests/dom/reloadevery1s.htm
2 - Bookmark the page
3 - Open a new tab, from the bookmarks tap on the same link again
4 - Repeat step 3
 
Expected result:
- Opening a new tab and loading the tapped link should work smoothly

Actual result:
- Tapping on the autocomplete entry very difficult, loading the bookmarks autocomplete entries very slow.

It seems especially slow on the Galaxy Nexus, especially showing the bookmarks autocomplete entries. But I can see the issue on the Galaxy SII too.
This sounds like a dupe of some of your other "do something a lot of times and performance slows down" bugs
(Reporter)

Comment 2

7 years ago
I don't consider reloading every second doing a lot in a small amount of time.
Stock brower has no problem handling at all.
Perhaps Fennec is doing some database queries after/during every reload or something?
(Assignee)

Updated

a year ago
Assignee: nobody → gbrown
Status: NEW → RESOLVED
Last Resolved: a year ago
Component: General → Testing
Priority: -- → P5
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.