Closed Bug 753305 Opened 8 years ago Closed 8 years ago

Change invitation template to use a standalone file

Categories

(Calendar :: E-mail based Scheduling (iTIP/iMIP), defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: Fallen, Assigned: Fallen)

References

(Blocks 1 open bug)

Details

(Whiteboard: [wanted-1.2.x])

Attachments

(1 file)

Attached patch Fix - v1 β€” β€” Splinter Review
Right now the whole html invitation is put together using e4x in lightningTextCalendarConverter.js. This makes it a lot of work to restyle things.

To open up more chances for the future, we can load the invitation template from an .xhtml file. This patch takes care.
Attachment #622364 - Flags: review?(laurent)
Comment on attachment 622364 [details] [diff] [review]
Fix - v1

Review of attachment 622364 [details] [diff] [review]:
-----------------------------------------------------------------

It's ok for me.

::: calendar/lightning/components/lightningTextCalendarConverter.js
@@ +64,4 @@
>  }
>  
> +/**
> + * Returns the string form of the html representation of the event

Fix the comment: it returns the DOM, not the string form

::: calendar/lightning/themes/common/imip.css
@@ +15,4 @@
>         width: 2em;
>         text-align: left;
>  }
> +th.header {

It seems that file has been already changed in comm-central. this modification seems to be useless.
Attachment #622364 - Flags: review?(laurent) → review+
I had to make another change to linkifyText, as the URLs were not being linkified correctly. I've taken care of the other comments and will push in a moment.
I forgot a thing in my review: you can remove the line 

>let stringBundle = Services.strings.createBundle("chrome://lightning/locale/lightning.properties");

It seems this variable is not used anymore...
Pushed to comm-central changeset e31710132acb
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Target Milestone: --- → 1.7
Whiteboard: [wanted-1.2.x]
Blocks: 466451
> Whiteboard: [wanted-1.2.x]

IMHO 1.2.x esr releases should get bug fixes only. But this is a feature and not a bug fix. If you want to port back to 1.2.x than you should consider port back to 1.6 and 1.5 first to allow at least some QA work. 1.7 is broken and can't be used for QA work.
No longer blocks: 466451
You need to log in before you can comment on or make changes to this bug.