Text rendering too big on formula1.com homepage featured article

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
6 years ago
6 years ago

People

(Reporter: cmore, Unassigned)

Tracking

15 Branch
Other
Android
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [Engagement][readability])

Attachments

(2 attachments)

(Reporter)

Description

6 years ago
Created attachment 622385 [details]
Fennec screenshot

Web page or screen you were on when you saw the issue: 

Steps to reproduce:
1. Use Fennec nightly 15
2. Visit www.formula1.com
3. Look at the paragraph next to the featured article and image on the homepage.

What you expected: 

The text size should look like it does on the iPhone safari browser. 

Actual:

The paragraph text for the featured article is about .3em larger.

See attached screenshots.
(Reporter)

Comment 1

6 years ago
Created attachment 622386 [details]
iPhone screenshot
I don't think this is a bug.  Both Safari and Fennec enlarge text on web pages for better readability, but we don't attempt to match Safari's inflation exactly.  You can also change the level of font inflation in the Fennec preferences (Settings: Font Size).
Blocks: 627842
Whiteboard: [Engagement] → [Engagement][readability]
(Reporter)

Comment 3

6 years ago
Then why does it look appropriately sized on Aurora, Fennec 14? I understand the readability for mobile and agree that we shouldn't be matching Safari exactly. I just wanted to know why there was a .3em difference between Aurora and Nightly on the same website and same device minute apart.

I will heck the font size setting later as I have not touched them since installing Fennec.
(Reporter)

Comment 4

6 years ago
*Check
Some font-inflation fixes like bug 746966 have landed in Nightly but not (yet) in Aurora, which may cause font-inflation to inflate text that was previous not inflated.
(Reporter)

Comment 6

6 years ago
(In reply to Matt Brubeck (:mbrubeck) from comment #5)
> Some font-inflation fixes like bug 746966 have landed in Nightly but not
> (yet) in Aurora, which may cause font-inflation to inflate text that was
> previous not inflated.

Would font inflation in Nightly 15 have the following be true? If I set the font size in Fennec to the following, the fonts are the same size.

Fennec 14 Aurora: Medium

Fennec 15 Aurora: Small

Is the font inflation in Nightly 15 what is causing the font of small to be equivalent to medium in Aurora 14?
(In reply to Chris More [:cmore] from comment #6)
> Is the font inflation in Nightly 15 what is causing the font of small to be
> equivalent to medium in Aurora 14?

In the latest Nightly and Aurora builds on my phone, "Small" in Nightly is the same as "Small" in Aurora, and so on.

I think what was happening before is that font inflation was broken on formula1.com in Aurora because of bug 746966, so in Aurora it always rendered the same size regardless of the your settings.  Now that bug 746966 is fixed in the latest Nightly and Aurora builds, the font should adjust to fit your screen according to your settings, in both versions.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Depends on: 746966
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.