If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Status

Infrastructure & Operations
Telecom
RESOLVED FIXED
5 years ago
4 years ago

People

(Reporter: jlin, Assigned: zero)

Tracking

Details

(Whiteboard: Verify all 550's are working correctly in YVR)

(Reporter)

Description

5 years ago
When plugging an IP550 deskphone into an ethernet port, the phone reports "failed to get boot parameters via DHCP"

Comment 1

5 years ago
What is the MAC?
Assignee: network-operations → server-ops-telecom
Component: Server Operations: Netops → Server Operations: Telecom
QA Contact: ravi → jdow
(Reporter)

Comment 2

5 years ago
the MAC for this phone is 0004F23469BF
(Reporter)

Comment 3

5 years ago
This occurs for more than one phone. I've tried 2 different phones.
(Reporter)

Comment 4

5 years ago
0004F23469BF is able to get an ip now, 0004F22C9F74 was also able to get an ip.

Comment 5

5 years ago
So things are working?  We can close the bug?  What was the fix?
(Reporter)

Comment 6

5 years ago
I patched in the 2nd ethernet deskports in the conference rooms on the occupied side of the office, and when I switched deskports the phones all of a sudden started booting up as intended and got ip assignments. Was there anything special about the conference room ports that were originally patched when you were here?

Comment 7

5 years ago
All A and C (where they exist) ports have been patched through.  What did you end up doing?  I'd like to not move or patch extras if they are not  needed and just find the root cause to the problem.

Comment 8

5 years ago
There were a large number of interfaces that were not configured correctly to be in the corp vlan.  I corrected this so you should be able to use all ports A and C as intended.

Please revert any unnecessary patches.
(Reporter)

Comment 9

5 years ago
Thanks for that.

Yes so for conference rooms, I patched the B port where C/D doesn't exist so there would be 2 ports in the room. I was intending to use one port for the phone, and one port would be open for people to use when they are in the conference room (should wired ethernet be needed). I could have used the passthrough port on the phone itself - didn't think about that one when I did it. But I only this this for the few rooms that was on the occupied side.

I am now back in Toronto, but I can note down the ports I patched so we can correct in future.
(Reporter)

Comment 10

5 years ago
Unfortunately a similar problem popped up with regards to deskports

2.1002A & C and 2.1001A & C

Roland Tanglao's IP550 phone MAC 0004F2346559 associated with extension x402 gets stuck at bootup on "waiting for network to initialize" when attached to these deskports.

When he moves the phone to another ethernet port in one of the conference rooms (2.1024B), it boots normally, connects to the pbx and can dial out to an external 1-604-xxx-xxxx number.

If you need more info let me know.
(Reporter)

Comment 11

5 years ago
davida reports 2.1007A, 2.1007C has similar issue (phone when plugged into these ports doesn't register with pbx)

Comment 12

5 years ago
Assigning to Tim to work with Telecom since he will be in YVR this week.
Assignee: server-ops-telecom → tfairfield

Comment 13

5 years ago
This sounds like a firmware issue.  This issue is being worked in https://bugzilla.mozilla.org/show_bug.cgi?id=763123.  Keeping this bug open for now and we'll revisit it when that bug is resolved.
Depends on: 763123

Updated

5 years ago
Assignee: tfairfield → peter

Comment 14

5 years ago
Jonathan, is this still an issue?
(Reporter)

Comment 15

5 years ago
For davida, after a phone reset + reflash, his phone, plugged into Port C (2.1007C) can register on the pbx and has successfully made a call to x695 (my extension) in testing. 

He reports that when plugging into port A, the phone didn't power up at all (probably poe disabled) - he is fine with that - he'll just use A for other devices.

Peter will be traveling up to Vancouver so he will be able to hands-on verify.

Comment 16

5 years ago
Ok, are there any phones known to still not be working?
(Assignee)

Updated

5 years ago
Whiteboard: Verify all 550's are working correctly in YVR
(Reporter)

Comment 17

5 years ago
phones are able to get dhcp and register on the pbx provided they are reset and flashed.

closing this bug. new bugs will be opened for any phones that are still unable to connect.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Product: mozilla.org → Infrastructure & Operations
You need to log in before you can comment on or make changes to this bug.