StrictModeDiskReadViolation from SyncConfiguration.loadFromPrefs()

RESOLVED DUPLICATE of bug 717436

Status

()

Firefox for Android
General
RESOLVED DUPLICATE of bug 717436
6 years ago
6 years ago

People

(Reporter: cpeterson, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
Created attachment 622445 [details]
StrictModeDiskReadViolation.log

See the attached log for more details.

I/GlobalSession(22535): Running next stage fetchInfoCollections (org.mozilla.gecko.sync.stage.FetchInfoCollectionsStage@41791eb8)...
D/StrictMode(22535): StrictMode policy violation; ~duration=80 ms: android.os.StrictMode$StrictModeDiskReadViolation: policy=31 violation=2
D/StrictMode(22535): 	at android.os.StrictMode$AndroidBlockGuardPolicy.onReadFromDisk(StrictMode.java:1089)
D/StrictMode(22535): 	at android.app.SharedPreferencesImpl.awaitLoadedLocked(SharedPreferencesImpl.java:184)
D/StrictMode(22535): 	at android.app.SharedPreferencesImpl.contains(SharedPreferencesImpl.java:249)
D/StrictMode(22535): 	at org.mozilla.gecko.sync.SyncConfiguration.loadFromPrefs(SyncConfiguration.java:240)
D/StrictMode(22535): 	at org.mozilla.gecko.sync.SyncConfiguration.<init>(SyncConfiguration.java:220)
D/StrictMode(22535): 	at org.mozilla.gecko.sync.GlobalSession.<init>(GlobalSession.java:150)
D/StrictMode(22535): 	at org.mozilla.gecko.sync.syncadapter.SyncAdapter.performSync(SyncAdapter.java:387)
D/StrictMode(22535): 	at org.mozilla.gecko.sync.syncadapter.SyncAdapter$1.run(SyncAdapter.java:305)
D/StrictMode(22535): 	at android.accounts.AccountManager$10.run(AccountManager.java:1264)
D/StrictMode(22535): 	at android.os.Handler.handleCallback(Handler.java:605)
D/StrictMode(22535): 	at android.os.Handler.dispatchMessage(Handler.java:92)
D/StrictMode(22535): 	at android.os.Looper.loop(Looper.java:137)
D/StrictMode(22535): 	at android.app.ActivityThread.main(ActivityThread.java:4424)
D/StrictMode(22535): 	at java.lang.reflect.Method.invokeNative(Native Method)
D/StrictMode(22535): 	at java.lang.reflect.Method.invoke(Method.java:511)
D/StrictMode(22535): 	at com.android.internal.os.ZygoteInit$MethodAndArgsCaller.run(ZygoteInit.java:784)
D/StrictMode(22535): 	at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:551)
D/StrictMode(22535): 	at dalvik.system.NativeStart.main(Native Method)
(Reporter)

Comment 1

6 years ago
I'm running Nightly 15 on a Galaxy Nexus.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 717436
You need to log in before you can comment on or make changes to this bug.