Go Next Unread does nothing after shift-deleting all messages from a folder...

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
7 years ago
a year ago

People

(Reporter: fred, Unassigned)

Tracking

12 Branch
x86
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_6_8) AppleWebKit/535.19 (KHTML, like Gecko) Chrome/18.0.1025.168 Safari/535.19

Steps to reproduce:

Selected all messages in a folder.
Hit Shift-Delete to delete them all
Hit n to go to next unread message in other folders.


Actual results:

Nothing.  Did not got to next unread message.


Expected results:

Should have gone to next unread message in another folder.

More Info:
- This is a recent bug.  I've allowed auto-updates to new versions of Thunderbird
  for several months, so I'm always running the latest version.  This problem 
  occurs in version 11.0 and in version 12.0.1, but it hasn't been around for much
  longer than that.  I'm not sure what version I was using when it last worked, 
  but it was within the past month or so.
- I'm using Mac OS X Snow Leopard
- Works fine if I delete the messages one at a time via Shift-Delete and then hit
  n once the folder is empty.  Problem only occurs if I select all (via Cmd-A, or
  via multiple Shift-Down arrows) and then Shift-Delete then hit n.

Comment 1

7 years ago
(In reply to Fred Stluka from comment #0)
Works for me (in local folder):
User Agent: Mozilla/5.0 (X11; Linux i686; rv:12.0) Gecko/20120428 Thunderbird/12.0.1
Application Build ID: 20120428123100
wfm tb12/winxp.

Can someone test this on MAC? (Simple STR in comment 0)
I cannot reproduce this with 52.2.0 on Windows.
Can you reproduce on Mac?
Flags: needinfo?(e.berberich)

Comment 4

a year ago
(In reply to Wayne Mery (:wsmwk, NI for questions) from comment #3)
> I cannot reproduce this with 52.2.0 on Windows.
> Can you reproduce on Mac?

Running macOS Sierra now I cannot reproduce this issue with Thunderbird 52.2.1.
Flags: needinfo?(e.berberich)
Thanks
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 6

a year ago
Still happens to me most days.  I'm on TBird 52.2.1 on Mac OS X 10.11.6 El Capitan.

I tried to repeat it just now, and it didn't happen.  So perhaps there's more to
the pattern.  Typically, I use "n" to cycle through all my folders that have unread
messages, reading and sometimes filing or deleting them.  My last folder is a 
catchall that contains mostly spam, so I usually end up selecting many and deleting
them all with Shift-Delete.  Then I type "n" again to cycle around to the top because
by then more new messages have typically come in.  Or I hit Shift-F5 to fetch all 
new messages from all POP accounts, and then hit "n".  At least once per day, I 
notice that "n" does nothing in this case, even though there ARE new unread 
messages in the earlier folders.  If I then click on a different folder and hit
"n" again, it works fine.  And if I always make a habit of selecting all but one
of the messages in the catchall folder, then hitting Shift-Delete, which leaves
the one last message highlighted, then hitting Shift-Delete again to delete just
that one message, then hitting "n", it works fine.

--Fred
You need to log in before you can comment on or make changes to this bug.