All users were logged out of Bugzilla on October 13th, 2018

crash in JS_GetFlatStringChars

RESOLVED WORKSFORME

Status

()

--
critical
RESOLVED WORKSFORME
7 years ago
6 years ago

People

(Reporter: scoobidiver, Unassigned)

Tracking

({crash, regression})

15 Branch
x86_64
Windows 7
crash, regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [js:inv:p2], crash signature)

(Reporter)

Description

7 years ago
With that stack, it first appeared in 15.0a1/20120509. The regression range is:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=1092c1a3ac50&tochange=dd29535bac5f
I think it's a regression from bug 752737.

Signature 	JS_GetFlatStringChars More Reports Search
UUID	fee9fd4f-7f5e-4777-bd43-e21bb2120510
Date Processed	2012-05-10 03:16:09
Uptime	1601
Last Crash	4.9 days before submission
Install Age	1.4 hours since version was first installed.
Install Time	2012-05-10 01:54:03
Product	Firefox
Version	15.0a1
Build ID	20120509030514
Release Channel	nightly
OS	Windows NT
OS Version	6.1.7601 Service Pack 1
Build Architecture	amd64
Build Architecture Info	family 6 model 37 stepping 5
Crash Reason	EXCEPTION_ACCESS_VIOLATION_READ
Crash Address	0xffffffffffffffff
App Notes 	
AdapterVendorID: 0x8086, AdapterDeviceID: 0x0046, AdapterSubsysID: 21d917aa, AdapterDriverVersion: 8.15.10.2401
Has dual GPUs. GPU #2: AdapterVendorID2: 0x10de, AdapterDeviceID2: 0x0a6c, AdapterSubsysID2: 21d817aa, AdapterDriverVersion2: 8.17.12.7593D2D? D2D+ DWrite? DWrite+ D3D10 Layers? D3D10 Layers+ 
Processor Notes 	
EMCheckCompatibility	False
Total Virtual Memory	8796092891136
Available Virtual Memory	8795049709568
System Memory Use Percentage	63
Available Page File	4078481408
Available Physical Memory	1500962816

Frame 	Module 	Signature 	Source
0 	xul.dll 	JS_GetFlatStringChars 	js/src/jsfriendapi.cpp:185
1 	xul.dll 	nsXPConnect::CheckForDebugMode 	js/xpconnect/src/nsXPConnect.cpp:2411
2 	xul.dll 	nsXPConnect::Push 	js/xpconnect/src/nsXPConnect.cpp:2500
3 	xul.dll 	nsCxPusher::Push 	content/base/src/nsContentUtils.cpp:2957
4 	xul.dll 	nsCxPusher::RePush 	content/base/src/nsContentUtils.cpp:2985
5 	xul.dll 	nsEventListenerManager::HandleEventInternal 	content/events/src/nsEventListenerManager.cpp:891
6 	xul.dll 	nsEventTargetChainItem::HandleEventTargetChain 	content/events/src/nsEventDispatcher.cpp:349
7 	xul.dll 	nsRefPtr<nsRunnableMethod<nsDocument,void,1> >::assign_with_AddRef 	obj-firefox/xpcom/build/nsCOMPtr.cpp:88
8 	xul.dll 	nsEventDispatcher::Dispatch 	content/events/src/nsEventDispatcher.cpp:675
9 	xul.dll 	Reify 	js/src/jswrapper.cpp:699
10 	xul.dll 	nsScriptSecurityManager::IsCapabilityEnabled 	caps/src/nsScriptSecurityManager.cpp:2601
11 	xul.dll 	nsEventDispatcher::DispatchDOMEvent 	content/events/src/nsEventDispatcher.cpp:738
12 	xul.dll 	nsXULDocument::AddRef 	content/xul/document/src/nsXULDocument.cpp:399
13 	xul.dll 	nsINode::DispatchEvent 	content/base/src/nsGenericElement.cpp:1165
14 	xul.dll 	nsIDOMEventTarget_DispatchEvent 	obj-firefox/js/xpconnect/src/dom_quickstubs.cpp:10240
15 	xul.dll 	js::InvokeKernel 	js/src/jsinterp.cpp:524
16 	xul.dll 	js::Interpret 	js/src/jsinterp.cpp:2745
17 	xul.dll 	nsXPConnect::WrapNativeToJSVal 	js/xpconnect/src/nsXPConnect.cpp:1321
...

More reports at:
https://crash-stats.mozilla.com/report/list?signature=JS_GetFlatStringChars
(Reporter)

Updated

7 years ago
Crash Signature: [@ JS_GetFlatStringChars] → [@ JS_GetFlatStringChars ]
(Reporter)

Updated

7 years ago
Crash Signature: [@ JS_GetFlatStringChars ] → [@ JS_GetFlatStringChars]
Whiteboard: [js:investigate][js:p1:fx16]
Whiteboard: [js:investigate][js:p1:fx16] → [js:inv:p2]

Comment 1

7 years ago
Definitely not bug 752737, the only generated code that would have altered was in JSAPI C++ tests, which are not part of the browser.

Comment 2

6 years ago
I get this issue as well, when I refresh about:memory during a large session it will do this on occasion.

bug report:
https://crash-stats.mozilla.com/report/index/bp-ec98a57b-9589-4e13-bd58-8cf792120708
(Reporter)

Comment 3

6 years ago
Crashes are gone after 15.0a1/20120512. I close it as WFM.

(In reply to Grant from comment #2)
> I get this issue as well, when I refresh about:memory during a large session
> it will do this on occasion.
After checking it still happen in the latest build, file a new bug because your stack trace is different.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.