Closed Bug 753669 Opened 8 years ago Closed 8 years ago

Flash images from an iframe gets orphaned when switching tabs

Categories

(Firefox for Android :: General, defect)

ARM
Android
defect
Not set
normal

Tracking

()

VERIFIED DUPLICATE of bug 750778
Tracking Status
blocking-fennec1.0 --- +

People

(Reporter: tchung, Assigned: snorp)

References

()

Details

Attachments

(1 file)

Attached image screenshot
This is a variation of bug 750760, with a slightly different STR.   bug 750760 is fixed, so i'm filing a new one.

on Sites where flash ads live in iframes, switching tabs and back will detach the flash image into a static spot.  and panning around does not stick.

See screencast: http://www.youtube.com/watch?v=Vx4njBieB4Q

This issue is also present in aurora and nightly.

Repro:
1) install Fennec Native 14 beta 1, Desire HD
2) visit URL, or any site with flash in iframe
3) tap to play plugin
4) when flash ad is visible, launch another tab (eg. goto about:firefox)
5) notice site looks fine
6) navigate back to previous tab where your flash ad is.  
7) pan the page.  Verify the flash ad from iframe is static, while panning the rest of the page doesnt affect the image still showing.

Expected:
- flash ad locks back into the iframe it was before when returning to site

Actual:
- flash ad is orphaned and floats.
Assignee: nobody → snorp
blocking-fennec1.0: ? → +
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 750778
ah, thats the bug i was looking for.  thanks!
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.