Download is displayed as completed if the Wifi connection is lost when the download is initiated in a new tab

RESOLVED WORKSFORME

Status

()

Firefox for Android
General
RESOLVED WORKSFORME
6 years ago
2 years ago

People

(Reporter: AdrianT, Unassigned)

Tracking

Trunk
ARM
Android
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [14.0b1])

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
Created attachment 622683 [details]
logs

Nightly/15.0a1 (2012-05-10) / Firefox 14.0b1 build 2
Device: HTC Desire
OS: Android 2.2.2

Steps to reproduce:
1. Go to a direct download link in a new tab. Try iris.nyit.edu/arthistory/shows/early_renaissance.ppt
2. While the file is downloading disable the WiFi connection.

Expected results:
Download is paused and resumed when the WiFi connection is re-enabled.

Actual results:
A notification that the file download has been completed is displayed in the Notification Bar. In the Download Manager the file is displayed as being downloaded.
Issue is only reproducible if the download is started in an empty/about:home tab. 
If the download is started in a used tab (a tab with a page loaded previously) the download is canceled and an error is displayed when Fennec is reopened.

Updated

6 years ago
Whiteboard: [14.0b1]
Is this feasible in Android?
I cannot reproduce this issue on the latest Nightly and Beta builds.

After step 2, a download error dialog is triggered in Firefox and in Downloads Manager the downloaded file is marked as failed. If I long tap on it, I will be able to Retry or to Delete it.

--
Firefox 17.0a1 (2012-08-08)
Device: Galaxy Nexus
OS: Android 4.1.1
(Reporter)

Comment 3

5 years ago
Closing as WFM since I am unable to reproduce the issue on the latest builds
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.