Closed Bug 753800 Opened 10 years ago Closed 10 years ago

full crashreporter symbols for osx contain all files duplicated

Categories

(Firefox Build System :: General, defect)

x86_64
Linux
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 587073

People

(Reporter: glandium, Unassigned)

Details

The zip uploaded to the crash server for osx builds contain duplicates of all files, which means
1) a waste of time compressing them
2) a probably waste of space on the crash server
3) a waste of time uploading them

Basically, what (I think) happens is that we have .dSYM bundles for all binaries stored once with the id of the 32-bits binary, and once with the id of the 64-bits binary, but in both cases, they are universal bundles.

They should either be unified (only put one copy) or separated (providing a 32-bit non-universal bundle and a 64-bit non-universal bundle). The latter sounds more backwards compatible.
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 587073
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.