Last Comment Bug 753807 - Land in comm-central Instantbird's changes to chat/
: Land in comm-central Instantbird's changes to chat/
Status: RESOLVED FIXED
:
Product: Thunderbird
Classification: Client Software
Component: Instant Messaging (show other bugs)
: Trunk
: All All
: -- normal (vote)
: Thunderbird 15.0
Assigned To: Florian Quèze [:florian] [:flo]
:
Mentors:
Depends on: 755334 776901 799068 812921
Blocks: 740451 753691 758527
  Show dependency treegraph
 
Reported: 2012-05-10 08:43 PDT by Florian Quèze [:florian] [:flo]
Modified: 2014-01-03 09:49 PST (History)
7 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
fixed


Attachments
32 changesets exported from Instantbird's repository (91.45 KB, patch)
2012-05-10 08:43 PDT, Florian Quèze [:florian] [:flo]
mozilla: feedback+
clokep: feedback+
Details | Diff | Splinter Review
33 changesets exported from Instantbird's repository - ready to land (97.20 KB, patch)
2012-05-15 03:55 PDT, Florian Quèze [:florian] [:flo]
no flags Details | Diff | Splinter Review
22 changesets for aurora (40.81 KB, patch)
2012-05-16 07:20 PDT, Florian Quèze [:florian] [:flo]
no flags Details | Diff | Splinter Review
Another 13 changesets for comm-central (60.22 KB, patch)
2012-05-25 07:16 PDT, Florian Quèze [:florian] [:flo]
no flags Details | Diff | Splinter Review
30 changesets for aurora (60.27 KB, patch)
2012-05-25 08:58 PDT, Florian Quèze [:florian] [:flo]
mozilla: approval‑comm‑aurora+
Details | Diff | Splinter Review

Description Florian Quèze [:florian] [:flo] 2012-05-10 08:43:59 PDT
Created attachment 622745 [details] [diff] [review]
32 changesets exported from Instantbird's repository

The changes that should be ported to comm-central are:
Bio 1284 - Fix a comment in prplIProtocol.idl mentioning PR_TRUE and PR_FALSE values, r=clokep.
Bio 1291 - Source displayed in "entered the room" system messages for JS-IRC is too verbose, r=fqueze.
Bio 1328 - /msg <nick> should open an empty conversation tab: Follow-up to 2ea0ec22990e to fix the case of trailing whitespace after a nick, r=clokep.
Bio 1327 - Commands are "not supported" when missing parameters or returning false, r=clokep.
Bio 1293 - Tooltip improvements for IRC: tweak the order of tooltip lines, r=clokep.
Bio 1354 - JS-protocols should close their conversations and remove their buddies when they are removed, r=clokep.
Bio 1332 - Implement /whois and /whowas commands, r=clokep,fqueze.
Bio 1314 - Own nickname (for pings) detection broken, r=clokep,fqueze.
Bio 1281 - Sending typing notifications even tho the option for it is disabled, r=fqueze.
Bio 1303 - IRC contacts don't get their status updated when no IRC contact is online, r=fqueze.
Bio 1303 - Update the status of IRC contacts immediately when we know they they joined or leaved a channel where we are, r=clokep.
Bio 1346 - Replace alphabetic increment of last letter on nick collision, r=aleth,fqueze.
Bio 1321 - Display name is lower case for IRC DMs, r=clokep,fqueze.
Bio 1306 - Joining a password protected IRC channel via password set in autojoin doesn't work with JS-IRC, r=aleth.
Bio 1305 - /mode messages don't work on JS-IRC, r=fqueze.
Bio 860 - Add reading position marker line to conversation, r=fqueze.
Bio 1372 - QUIT command with no message causes an error, r=fqueze.
Bio 1326 - Stop trying to send the action command if an empty message is given, r=aleth.
Bio 1373 - CTCP ERRMSG is handled poorly, r=fqueze.
Bio 1321 - Follow-up to 81717e6f64bd to fix some bustage when opening a private IRC conversation, r=fqueze.
Bio 1305 - /mode messages don't work on JS-IRC - follow-up to handle more cases, r=aleth.
Bio 1378 - Avoid sending empty nicks when changing modes with tab complete, r=aleth.
Bio 1389 - Warning: reference to undefined property this._lastScrollHeight, r=clokep.
Bio 1389 - Warning: reference to undefined property this._lastScrollHeight - fix bustage caused by 2eeb8a68d5a3, r=fqueze.
Bio 1366 - Inform the user when attempting to send a message to an offline nick, r=aleth,fqueze.
Bio 1357 - Add unread ruler to section scroll, r=fqueze.
Bio 1415 - display the unread ruler at the correct place even if messages were queued for asynchronous display when the first unread message arrived, r=fqueze.
Bio 1416 - JS-XMPP MUCs are duplicated after rejoining, r=clokep.
Bio 1418 - No/incorrect error message when joining a channel fails, r=aleth.
Bio 1415 - Unread ruler should also appear after last context message, r=fqueze.
Bio 1353 - No user feedback when sending a message in a conversation of an offline account, r=fqueze.
Bio 1429 - Failure to start when there's less than 500MB of free disk space, r=clokep.

I'm attaching a file that can be hg imported to comm-central.


The process I used to generate this file was:
1. create a new repository containing only the chat/ folder of Instantbird's repository using hg convert with a filemap file containing "include chat"
2. Export the changesets using hg export and specifying the first and last interesting revisions.
3. Edit the file by hand to remove the changesets that have been commited first to comm-central and then to hg.instantbird.org/instantbird later.
4. Check that all changesets have reasonable review and commit messages for landing in comm-central.

Notes:

- 1. Is needed because hg export can't restrict the content of the exported changesets to only modifications to a subfolder. hg log -p can, but doesn't print the commit messages and patch authors in a format that is suitable for hg import.

- 4. Isn't finished yet, I have some questions:
-- 5 of the 32 changesets only have r=aleth.
These 5 patches touch only IRC code, and the author for these patches is Patrick Cloke who is a peer of chat/ module. Is aleth's review enough, or do I need to add rs=florian to these changesets before then can land in comm-central?
-- The commits to Instantbird's repository of the patches where I'm the reviewer
tend to have r=fqueze. I've used r=florian in comm-central. Do I need to s/fqueze/florian/ on all the commit messages?
-- Currently all commit messages are prefixed with "Bug <number in bugzilla.instantbird.org> -". We obviously need to change that prefix as this prefix would cause invalid BMO links to be created in the hg pushlog for comm-central. Here's a proposal:
Bug <this bug's number> - Land in comm-central Instantbird's changes to chat/ - Bio <number in BIO> -"
Thoughts?

- This should be a lot less confusing once BIO is merged into BMO (bug 749586).
Comment 1 Patrick Cloke [:clokep] 2012-05-10 09:03:31 PDT
(In reply to Florian Quèze from comment #0)
> Created attachment 622745 [details] [diff] [review]
> -- Currently all commit messages are prefixed with "Bug <number in
> bugzilla.instantbird.org> -". We obviously need to change that prefix as
> this prefix would cause invalid BMO links to be created in the hg pushlog
> for comm-central. Here's a proposal:
> Bug <this bug's number> - Land in comm-central Instantbird's changes to
> chat/ - Bio <number in BIO> -"
> Thoughts?
Meaning that each changeset would be imported into c-c as an individual commit, but Attachment #622745 [details] [diff] is the aggregate of all changes, correct?

If so, I think that's fine.
Comment 2 Florian Quèze [:florian] [:flo] 2012-05-10 09:06:21 PDT
(In reply to Patrick Cloke [:clokep] from comment #1)
> [...] each changeset would be imported into c-c as an individual
> commit, but Attachment #622745 [details] [diff] is the aggregate of all
> changes, correct?

Yes.
Comment 3 Patrick Cloke [:clokep] 2012-05-10 09:16:23 PDT
Comment on attachment 622745 [details] [diff] [review]
32 changesets exported from Instantbird's repository

That seems fine to me then. Thanks for doing this Florian...I'm thinking we should do this more often in the future.
Comment 4 Florian Quèze [:florian] [:flo] 2012-05-15 03:55:43 PDT
Created attachment 623991 [details] [diff] [review]
33 changesets exported from Instantbird's repository - ready to land

Changes compared to attachment 622745 [details] [diff] [review]:

- I added this changeset that landed yesterday for Instantbird:
Bio 1409 - Handle (dis)connects better in IRC, r=fqueze. https://hg.instantbird.org/instantbird/rev/1afad9aa06d0

- I replaced the "Bug " prefix with a "Bug 753807 - Land in comm-central Instantbird's changes to chat/ - Bio " prefix in all commit messages.
Comment 5 Florian Quèze [:florian] [:flo] 2012-05-15 03:59:59 PDT
https://hg.mozilla.org/comm-central/rev/0f32637ddd1f
https://hg.mozilla.org/comm-central/rev/784514d93828
https://hg.mozilla.org/comm-central/rev/349fdaf0ab03
https://hg.mozilla.org/comm-central/rev/512a81b18b06
https://hg.mozilla.org/comm-central/rev/6daa883d0f48
https://hg.mozilla.org/comm-central/rev/c8c6cea29b05
https://hg.mozilla.org/comm-central/rev/e7b24610db13
https://hg.mozilla.org/comm-central/rev/6e6a697a8def
https://hg.mozilla.org/comm-central/rev/1a6985efaaaa
https://hg.mozilla.org/comm-central/rev/1d96ce17733b
https://hg.mozilla.org/comm-central/rev/e0190b49d59c
https://hg.mozilla.org/comm-central/rev/5dbcb6d638bf
https://hg.mozilla.org/comm-central/rev/42e874815e9c
https://hg.mozilla.org/comm-central/rev/180f977a6795
https://hg.mozilla.org/comm-central/rev/4a15b94f0f50
https://hg.mozilla.org/comm-central/rev/11a59aa41185
https://hg.mozilla.org/comm-central/rev/df5e87982686
https://hg.mozilla.org/comm-central/rev/33331bf1249c
https://hg.mozilla.org/comm-central/rev/73eaf78dac0d
https://hg.mozilla.org/comm-central/rev/730bfca714a6
https://hg.mozilla.org/comm-central/rev/196d01653d2e
https://hg.mozilla.org/comm-central/rev/72b0aeacb898
https://hg.mozilla.org/comm-central/rev/1d16346cd1b6
https://hg.mozilla.org/comm-central/rev/3f522691ebaa
https://hg.mozilla.org/comm-central/rev/dfa853902632
https://hg.mozilla.org/comm-central/rev/dd217d44bf22
https://hg.mozilla.org/comm-central/rev/4011d6af5f15
https://hg.mozilla.org/comm-central/rev/3394844340a9
https://hg.mozilla.org/comm-central/rev/ef3601c338e3
https://hg.mozilla.org/comm-central/rev/e10809cef1cf
https://hg.mozilla.org/comm-central/rev/d628238bd824
https://hg.mozilla.org/comm-central/rev/81031e80b6cd
https://hg.mozilla.org/comm-central/rev/2d68a2e7b53f
Comment 6 Onno Ekker [:nONoNonO UTC+1] 2012-05-15 04:35:52 PDT
These changes won't get ported to Thunderbird 14.0?
Comment 7 Florian Quèze [:florian] [:flo] 2012-05-15 05:54:00 PDT
(In reply to Onno Ekker from comment #6)
> These changes won't get ported to Thunderbird 14.0?

Some of them will, but I can't just request approval-aurora on attachment 623991 [details] [diff] [review] as some of the changesets included in it require string changes.
Comment 8 Florian Quèze [:florian] [:flo] 2012-05-15 10:30:23 PDT
I looked at that list of changesets and discussed with other people of the Instantbird team what we feel could go to aurora.

Here's my/our proposal:

I recommend taking these changesets to comm-aurora:
+ Bio 1284 - Fix a comment in prplIProtocol.idl mentioning PR_TRUE and PR_FALSE values, r=clokep.
+ Bio 1328 - /msg <nick> should open an empty conversation tab: Follow-up to 2ea0ec22990e to fix the case of trailing whitespace after a nick, r=clokep.
+ Bio 1327 - Commands are "not supported" when missing parameters or returning false, r=clokep.
+ Bio 1293 - Tooltip improvements for IRC: tweak the order of tooltip lines, r=clokep.
+ Bio 1354 - JS-protocols should close their conversations and remove their buddies when they are removed, r=clokep.
+ Bio 1314 - Own nickname (for pings) detection broken, r=clokep,fqueze.
+ Bio 1281 - Sending typing notifications even tho the option for it is disabled, r=fqueze.
+ Bio 1303 - IRC contacts don't get their status updated when no IRC contact is online, r=fqueze.
+ Bio 1303 - Update the status of IRC contacts immediately when we know they they joined or leaved a channel where we are, r=clokep.
+ Bio 1346 - Replace alphabetic increment of last letter on nick collision, r=aleth,fqueze.
+ Bio 1306 - Joining a password protected IRC channel via password set in autojoin doesn't work with JS-IRC, r=aleth.
+ Bio 1305 - /mode messages don't work on JS-IRC, r=fqueze.
+ Bio 1372 - QUIT command with no message causes an error, r=fqueze.
+ Bio 1326 - Stop trying to send the action command if an empty message is given, r=aleth.
+ Bio 1373 - CTCP ERRMSG is handled poorly, r=fqueze.
(+ without the changed string) Bio 1305 - /mode messages don't work on JS-IRC - follow-up to handle more cases, r=aleth.
+ Bio 1378 - Avoid sending empty nicks when changing modes with tab complete, r=aleth.
+ Bio 1389 - Warning: reference to undefined property this._lastScrollHeight, r=clokep.
+ Bio 1389 - Warning: reference to undefined property this._lastScrollHeight - fix bustage caused by 2eeb8a68d5a3, r=fqueze.
+ Bio 1416 - JS-XMPP MUCs are duplicated after rejoining, r=clokep.
+ Bio 1418 - No/incorrect error message when joining a channel fails, r=aleth.
+ Bio 1429 - Failure to start when there's less than 500MB of free disk space, r=clokep.
+ Bio 1409 - Handle (dis)connects better in IRC, r=fqueze.


Unsuitable for aurora because of required string changes:
- Bio 1291 - Source displayed in "entered the room" system messages for JS-IRC is too verbose, r=fqueze.
- Bio 1332 - Implement /whois and /whowas commands, r=clokep,fqueze.
- Bio 1321 - (requires bio 1332 which requires string changes) Display name is lower case for IRC DMs, r=clokep,fqueze.
- Bio 1321 - Follow-up to 81717e6f64bd to fix some bustage when opening a private IRC conversation, r=fqueze.
- Bio 1366 - Inform the user when attempting to send a message to an offline nick, r=aleth,fqueze.
- Bio 1353 - No user feedback when sending a message in a conversation of an offline account, r=fqueze.


The back-end code for the 'unread ruler' new feature could technically go to aurora as it doesn't require string changes, but without adding some front end changes (that haven't been written yet) there's no benefit at all to Thunderbird, so I would recommand that we don't port these changesets to aurora:
=(-?) Bio 860 - Add reading position marker line to conversation, r=fqueze.
=(-?) Bio 1357 - Add unread ruler to section scroll, r=fqueze.
=(-?) Bio 1415 - display the unread ruler at the correct place even if messages were queued for asynchronous display when the first unread message arrived, r=fqueze.
=(-?) Bio 1415 - Unread ruler should also appear after last context message, r=fqueze.

David (or anybody else who can grant the approval-comm-aurora flag), I would like some feedback on that list before preparing an attachment on which I will request approval.
Comment 9 David :Bienvenu 2012-05-15 10:59:19 PDT
Florian, that list looks reasonable to me.
Comment 10 Florian Quèze [:florian] [:flo] 2012-05-16 07:07:49 PDT
Actually,
+ Bio 1418 - No/incorrect error message when joining a channel fails, r=aleth.

depends on:
- Bio 1366 - Inform the user when attempting to send a message to an offline nick, r=aleth,fqueze.

So I'm not going to include this one in my aurora set of patches.
Comment 11 Florian Quèze [:florian] [:flo] 2012-05-16 07:20:01 PDT
Created attachment 624374 [details] [diff] [review]
22 changesets for aurora

Attachment following my proposal in comment 8, minus the "Bio 1418 - No/incorrect error message when joining a channel fails" changeset, for the reason explained in comment 10.
Comment 12 Axel Hecht [:Pike] 2012-05-16 14:41:38 PDT
Re http://hg.mozilla.org/comm-central/diff/e7b24610db13/chat/locales/en-US/irc.properties#l1.35

The usage of 2 character unicode escapes is rather brittle, I suggest to use 4 character ones, or rather, utf-8 encode the strings to begin with. Which localizer would know what \ua0 is. TBH, I don't. If there's something special, it might be good to add a localization note, too.

PS: code-pointer is http://hg.mozilla.org/mozilla-central/file/65fb8b9ea0b7/xpcom/ds/nsPersistentProperties.cpp#l337, that code only terminates reliably on 4 chars of unicode, otherwise it just stops when it sees "junk".
Comment 13 Florian Quèze [:florian] [:flo] 2012-05-16 15:35:46 PDT
(In reply to Axel Hecht [:Pike] from comment #12)
> Re
> http://hg.mozilla.org/comm-central/diff/e7b24610db13/chat/locales/en-US/irc.
> properties#l1.35
> 
> The usage of 2 character unicode escapes is rather brittle, I suggest to use
> 4 character ones, or rather, utf-8 encode the strings to begin with. Which
> localizer would know what \ua0 is. TBH, I don't. If there's something
> special, it might be good to add a localization note, too.

I asked aleth (the author of this changeset) about this and here is his reply:
"I got that character off MDN, from its localization docs...
https://developer.mozilla.org/en/Frequently_Asked_Localization_Questions
I would have documented what it was if I had come up with it myself."

It seems you wrote that page (years ago...), so if it's no longer the recommended way to include unbreakable spaces in properties files, it would be nice to update it.
Comment 14 Florian Quèze [:florian] [:flo] 2012-05-24 05:36:04 PDT
> Bio 1409 - Handle (dis)connects better in IRC, r=fqueze.

This changeset is causing a serious regression (discussed in https://bugzilla.instantbird.org/show_bug.cgi?id=1455) mostly caused by bug 711786, so I'm no longer willing to take that specific changeset to aurora until we have a fix for the regression.
Comment 15 Florian Quèze [:florian] [:flo] 2012-05-25 07:16:20 PDT
Created attachment 627220 [details] [diff] [review]
Another 13 changesets for comm-central

In the future I think it will be better to open new bugs for additional changesets that we import from the instantbird repository, but as attachment 624374 [details] [diff] [review] hasn't landed yet on aurora, I'll update it here with the relevant subsets of both attachment 623991 [details] [diff] [review] and this new attachment, so I'm attaching new changesets here.
Comment 16 Florian Quèze [:florian] [:flo] 2012-05-25 07:20:33 PDT
I forgot to paste in comment 15 the list of changesets included in attachment 627220 [details] [diff] [review]:

Bio 1369 - Support WATCH and MONITOR for IRC, r=aleth.
Bio 1308 - "Adding a chat buddy twice" errors (JS-IRC sending bad chat-buddy-add notifications), r=clokep.
Bio 1442 - IRC messages that need a : for the last parameter broken, r=aleth.
Bio 1433 - Switching status from OFFLINE to UNAVAILABLE actually sets status to AVAILABLE, r=clokep.
Bio 1447 - Stop requesting WHOIS information when offline, r=fqueze.
Bio 1449 - Make initialization state of Core available and send notification when initialization finishes, r=fqueze.
Bio 318 - Check if topic on IRC channels is editable and make UI respond accordingly, r=aleth,fqueze.
Bio 1455 - IRC accounts connected through SSL cause random hangs, r=clokep.
Bio 1464 - this._proxyCancel is null error from socket.jsm, r=clokep.
Bio 1465 - The first connection attempt of new accounts with non-default settings shouldn't be aborted immediately, r=clokep.
Follow-up to Bio 318 - Check if topic on IRC channels is editable and make UI respond accordingly, r=aleth.
Bio 1446 - Reset nick when reconnecting and ensure conversations are notified of nick changes, r=clokep.
Bio 1466 - Clearing the topic doesn't update the UI and instead displays the previous topic in a system message, r=fqueze.
Comment 18 Florian Quèze [:florian] [:flo] 2012-05-25 08:58:49 PDT
Created attachment 627244 [details] [diff] [review]
30 changesets for aurora

[Approval Request Comment]

This includes attachment 624374 [details] [diff] [review] and 8 changesets from attachment 627220 [details] [diff] [review]:
+ Bio 1308 - "Adding a chat buddy twice" errors (JS-IRC sending bad chat-buddy-add notifications), r=clokep.
+ Bio 1433 - Switching status from OFFLINE to UNAVAILABLE actually sets status to AVAILABLE, r=clokep.
+ Bio 1447 - Stop requesting WHOIS information when offline, r=fqueze.
+ Bio 1449 - Make initialization state of Core available and send notification when initialization finishes, r=fqueze.
+ Bio 1455 - IRC accounts connected through SSL cause random hangs, r=clokep.
+ Bio 1464 - this._proxyCancel is null error from socket.jsm, r=clokep.
+ Bio 1465 - The first connection attempt of new accounts with non-default settings shouldn't be aborted immediately, r=clokep.
+ Bio 1446 - Reset nick when reconnecting and ensure conversations are notified of nick changes, r=clokep.

Changesets from attachment 627220 [details] [diff] [review] that I think shouldn't be taken to aurora:
- (not included because risky) Bio 1369 - Support WATCH and MONITOR for IRC, r=aleth.
- (regression from 1369 that's not included) Bio 1442 - IRC messages that need a : for the last parameter broken, r=aleth.
- (requires string changes) Bio 318 - Check if topic on IRC channels is editable and make UI respond accordingly, r=aleth,fqueze.
- (Bio 318 not included) Follow-up to Bio 318 - Check if topic on IRC channels is editable and make UI respond accordingly, r=aleth.
- (regression from 1369 that's not included) Bio 1466 - Clearing the topic doesn't update the UI and instead displays the previous topic in a system message, r=fqueze.
Comment 19 Florian Quèze [:florian] [:flo] 2012-05-25 10:29:15 PDT
I disabled a broken unit test: https://hg.mozilla.org/comm-central/rev/fef7d27efeaa

Patrick will investigate the issue soon.
Comment 20 Florian Quèze [:florian] [:flo] 2012-05-29 09:03:14 PDT
(In reply to Florian Quèze from comment #19)
> I disabled a broken unit test:
> https://hg.mozilla.org/comm-central/rev/fef7d27efeaa
> 
> Patrick will investigate the issue soon.

Fixed an re-enabled in https://hg.mozilla.org/comm-central/rev/e94df99864e1 - Bio 1468 - Fix (and re-enable) failing test from bio 1446, r=florian.
Comment 21 Florian Quèze [:florian] [:flo] 2012-05-31 07:01:00 PDT
https://hg.mozilla.org/releases/comm-aurora/rev/61d68b13dcfa
https://hg.mozilla.org/releases/comm-aurora/rev/87422d03cf05
https://hg.mozilla.org/releases/comm-aurora/rev/a5a480ad45f8
https://hg.mozilla.org/releases/comm-aurora/rev/8b71b46ccb35
https://hg.mozilla.org/releases/comm-aurora/rev/5b5ba952323b
https://hg.mozilla.org/releases/comm-aurora/rev/6cb9e19ad714
https://hg.mozilla.org/releases/comm-aurora/rev/88b7032afa27
https://hg.mozilla.org/releases/comm-aurora/rev/55989837998e
https://hg.mozilla.org/releases/comm-aurora/rev/8c6ab6f7b8fa
https://hg.mozilla.org/releases/comm-aurora/rev/2547ea69e001
https://hg.mozilla.org/releases/comm-aurora/rev/061a3a902926
https://hg.mozilla.org/releases/comm-aurora/rev/c2ed73653ed9
https://hg.mozilla.org/releases/comm-aurora/rev/f1e4038bf160
https://hg.mozilla.org/releases/comm-aurora/rev/6f44d81f5c34
https://hg.mozilla.org/releases/comm-aurora/rev/72f7db6bd86e
https://hg.mozilla.org/releases/comm-aurora/rev/7e04857437e4
https://hg.mozilla.org/releases/comm-aurora/rev/3995edb2e9b1
https://hg.mozilla.org/releases/comm-aurora/rev/7260178f00b4
https://hg.mozilla.org/releases/comm-aurora/rev/79b9c9e6dfc3
https://hg.mozilla.org/releases/comm-aurora/rev/aa82716179b6
https://hg.mozilla.org/releases/comm-aurora/rev/c7ce4db711e1
https://hg.mozilla.org/releases/comm-aurora/rev/7e0907f70656
https://hg.mozilla.org/releases/comm-aurora/rev/85c272be2876
https://hg.mozilla.org/releases/comm-aurora/rev/5525a74e282a
https://hg.mozilla.org/releases/comm-aurora/rev/745cb0123698
https://hg.mozilla.org/releases/comm-aurora/rev/4edfad0d82e6
https://hg.mozilla.org/releases/comm-aurora/rev/015af8fba954
https://hg.mozilla.org/releases/comm-aurora/rev/424316e9bae8
https://hg.mozilla.org/releases/comm-aurora/rev/b8f097b4b0df
https://hg.mozilla.org/releases/comm-aurora/rev/93ce37b318c1
https://hg.mozilla.org/releases/comm-aurora/rev/6445494bf621
Comment 22 Patrick Cloke [:clokep] 2014-01-03 09:47:23 PST
(In reply to Florian Quèze [:florian] [:flo] from comment #0)
> - This should be a lot less confusing once BIO is merged into BMO (bug
> 749586).
This is done now, so let's include a nicer mapping of these bugs:

> Created attachment 622745 [details] [diff] [review]
> 32 changesets exported from Instantbird's repository
>
> The changes that should be ported to comm-central are:
foo
> Bug 954716 - Fix a comment in prplIProtocol.idl mentioning PR_TRUE and
> PR_FALSE values, r=clokep.
foo
> Bug 954723 - Source displayed in "entered the room" system messages for JS-IRC
> is too verbose, r=fqueze.
foo
> Bug 954760 - /msg <nick> should open an empty conversation tab: Follow-up to
> 2ea0ec22990e to fix the case of trailing whitespace after a nick, r=clokep.
foo
> Bug 954759 - Commands are "not supported" when missing parameters or returning
> false, r=clokep.
foo
> Bug 954725 - Tooltip improvements for IRC: tweak the order of tooltip lines,
> r=clokep.
foo
> Bug 954788 - JS-protocols should close their conversations and remove their
> buddies when they are removed, r=clokep.
foo
> Bug 954764 - Implement /whois and /whowas commands, r=clokep,fqueze.
foo
> Bug 954746 - Own nickname (for pings) detection broken, r=clokep,fqueze.
foo
> Bug 954713 - Sending typing notifications even tho the option for it is
> disabled, r=fqueze.
foo
> Bug 954735 - IRC contacts don't get their status updated when no IRC contact
> is online, r=fqueze.
foo
> Bug 954735 - Update the status of IRC contacts immediately when we know they
> they joined or leaved a channel where we are, r=clokep.
foo
> Bug 954780 - Replace alphabetic increment of last letter on nick collision,
> r=aleth,fqueze.
foo
> Bug 954753 - Display name is lower case for IRC DMs, r=clokep,fqueze.
foo
> Bug 954738 - Joining a password protected IRC channel via password set in
> autojoin doesn't work with JS-IRC, r=aleth.
foo
> Bug 954737 - /mode messages don't work on JS-IRC, r=fqueze.
foo
> Bug 954293 - Add reading position marker line to conversation, r=fqueze.
foo
> Bug 954806 - QUIT command with no message causes an error, r=fqueze.
foo
> Bug 954758 - Stop trying to send the action command if an empty message is
> given, r=aleth.
foo
> Bug 954807 - CTCP ERRMSG is handled poorly, r=fqueze.
foo
> Bug 954753 - Follow-up to 81717e6f64bd to fix some bustage when opening a
> private IRC conversation, r=fqueze.
foo
> Bug 954737 - /mode messages don't work on JS-IRC - follow-up to handle more
> cases, r=aleth.
foo
> Bug 954813 - Avoid sending empty nicks when changing modes with tab complete,
> r=aleth.
foo
> Bug 954824 - Warning: reference to undefined property this._lastScrollHeight,
> r=clokep.
foo
> Bug 954824 - Warning: reference to undefined property this._lastScrollHeight -
> fix bustage caused by 2eeb8a68d5a3, r=fqueze.
foo
> Bug 954800 - Inform the user when attempting to send a message to an offline
> nick, r=aleth,fqueze.
foo
> Bug 954791 - Add unread ruler to section scroll, r=fqueze.
foo
> Bug 954850 - display the unread ruler at the correct place even if messages
> were queued for asynchronous display when the first unread message arrived,
> r=fqueze.
foo
> Bug 954851 - JS-XMPP MUCs are duplicated after rejoining, r=clokep.
foo
> Bug 954853 - No/incorrect error message when joining a channel fails, r=aleth.
foo
> Bug 954850 - Unread ruler should also appear after last context message,
> r=fqueze.
foo
> Bug 954787 - No user feedback when sending a message in a conversation of an
> offline account, r=fqueze.
foo
> Bug 954864 - Failure to start when there's less than 500MB of free disk space,
> r=clokep.

(In reply to Florian Quèze [:florian] [:flo] from comment #16)
> I forgot to paste in comment 15 the list of changesets included in
> attachment 627220 [details] [diff] [review]:
>
foo
> Bug 954803 - Support WATCH and MONITOR for IRC, r=aleth.
foo
> Bug 954740 - "Adding a chat buddy twice" errors (JS-IRC sending bad
> chat-buddy-add notifications), r=clokep.
foo
> Bug 954876 - IRC messages that need a : for the last parameter broken, r=aleth.
foo
> Bug 954868 - Switching status from OFFLINE to UNAVAILABLE actually sets status
> to AVAILABLE, r=clokep.
foo
> Bug 954881 - Stop requesting WHOIS information when offline, r=fqueze.
foo
> Bug 954883 - Make initialization state of Core available and send notification
> when initialization finishes, r=fqueze.
foo
> Bug 953761 - Check if topic on IRC channels is editable and make UI respond
> accordingly, r=aleth,fqueze.
foo
> Bug 954888 - IRC accounts connected through SSL cause random hangs, r=clokep.
foo
> Bug 954897 - this._proxyCancel is null error from socket.jsm, r=clokep.
foo
> Bug 954898 - The first connection attempt of new accounts with non-default
> settings shouldn't be aborted immediately, r=clokep.
foo
> Follow-up to Bug 953761 - Check if topic on IRC channels is editable and make
> UI respond accordingly, r=aleth.
foo
> Bug 954880 - Reset nick when reconnecting and ensure conversations are
> notified of nick changes, r=clokep.
foo
> Bug 954899 - Clearing the topic doesn't update the UI and instead displays the
> previous topic in a system message, r=fqueze.
Comment 23 Patrick Cloke [:clokep] 2014-01-03 09:49:06 PST
Oops I left a debug statement in the output! I'll fix that for the next one, sorry for the noise!

Note You need to log in before you can comment on or make changes to this bug.