Last Comment Bug 753845 - Race condition in selectTab causes all manner of badness
: Race condition in selectTab causes all manner of badness
Status: RESOLVED FIXED
:
Product: Firefox for Android
Classification: Client Software
Component: General (show other bugs)
: unspecified
: All Android
: -- normal (vote)
: Firefox 15
Assigned To: Kartikaya Gupta (email:kats@mozilla.com)
:
Mentors:
Depends on:
Blocks: 745250
  Show dependency treegraph
 
Reported: 2012-05-10 09:47 PDT by Kartikaya Gupta (email:kats@mozilla.com)
Modified: 2012-05-21 02:35 PDT (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
fixed
fixed
+


Attachments
Patch (2.05 KB, patch)
2012-05-10 09:47 PDT, Kartikaya Gupta (email:kats@mozilla.com)
margaret.leibovic: review+
mark.finkle: approval‑mozilla‑aurora+
Details | Diff | Review

Description Kartikaya Gupta (email:kats@mozilla.com) 2012-05-10 09:47:13 PDT
Created attachment 622763 [details] [diff] [review]
Patch

If the runnable in selectTab() starts running before selectTab() finishes, isSelectedTab(tab) fails and a bunch of Important Things (TM) don't happen.

Nom'ing for betaN+ blocker since this is probably the root cause for a bunch of bugs I've seen go by (things like titlebar not updating and such).
Comment 1 :Margaret Leibovic 2012-05-10 10:39:33 PDT
Comment on attachment 622763 [details] [diff] [review]
Patch

Good catch.
Comment 2 Kartikaya Gupta (email:kats@mozilla.com) 2012-05-10 10:43:18 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/33aee46739d7
Comment 3 Kartikaya Gupta (email:kats@mozilla.com) 2012-05-10 10:44:22 PDT
Comment on attachment 622763 [details] [diff] [review]
Patch

[Approval Request Comment]
Regression caused by (bug #): 
User impact if declined: randomly things won't update on switching tabs
Testing completed (on m-c, etc.): locally
Risk to taking this patch (and alternatives if risky): mobile-only
String changes made by this patch: none
Comment 4 Joe Drew (not getting mail) 2012-05-10 18:33:58 PDT
https://hg.mozilla.org/mozilla-central/rev/33aee46739d7
Comment 5 Kartikaya Gupta (email:kats@mozilla.com) 2012-05-11 14:26:17 PDT
https://hg.mozilla.org/releases/mozilla-aurora/rev/039532eb1c0d

Note You need to log in before you can comment on or make changes to this bug.