Closed Bug 753880 Opened 8 years ago Closed 8 years ago

Spacing for l10n languages are too small in portrait mode

Categories

(Firefox for Android :: General, defect)

14 Branch
defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 15
Tracking Status
firefox14 --- verified
firefox15 --- verified
blocking-fennec1.0 --- betaN+

People

(Reporter: nhirata, Assigned: Margaret)

Details

Attachments

(3 files)

Attached image French screenshot
1. install multilocale native fennec
2. switch to french
3. start fennec
4. go to awesome page.

Expected: you can read the text
Actual: various languages have parts of the text on the second line and it's cut off.
How does that compare to XF 10? At least for the German string, I wouldn't know an obvious fix.

Also CCing folks for German and French.
I see the same thing with a French Aurora build on my Nexus S. 

I don't see how we could make the second string shorter. Is there any way to reduce the font size or something?

FYI, things like that happen in lots of other localized native apps on Android. I think it's a general problem with their toolkit that each application has to work around.
Does the tab label support "marquee mode" (yes I am suggesting it) as a way to read the entire string?
(In reply to Mark Finkle (:mfinkle) from comment #4)
> Does the tab label support "marquee mode" (yes I am suggesting it) as a way
> to read the entire string?

You can set android:ellipsize="marquee" on a TextView. We do that in the HTML5 form validation popup. We'd just need to set it on the title TextView:
http://mxr.mozilla.org/mozilla-central/source/mobile/android/base/resources/layout/awesomebar_tab_indicator.xml#9
Sebastian, I'd suggest: "Meistbesucht". It's clear from context that it means sites.
If these labels only support one line items, why is there so much grey space between the url bar and the labels?

Kadir: Yes, that's also what I was thinking of. But are there Android devices which are smaller in portrait mode than the Nexus S? Because only a few pixels less and the last characters will drop into a new line.
blocking-fennec1.0: --- → ?
Margaret - Can you put the marquee the textview and see what happens?
Assignee: nobody → margaret.leibovic
betaN+ so we can get a bandaid ready ASAP
blocking-fennec1.0: ? → betaN+
Attached patch patchSplinter Review
As discussed on IRC, this just marquees the text on the selected tab. Also, it pauses at the beginning before/after marquee, so it doesn't  look too crazy. The overflow on the non-selected tabs just fades away.
Attachment #623780 - Flags: review?(mark.finkle)
Comment on attachment 623780 [details] [diff] [review]
patch

This is not the greatest way to fix the problem, but it makes it useable.
Attachment #623780 - Flags: review?(mark.finkle) → review+
Comment on attachment 623780 [details] [diff] [review]
patch

[Approval Request Comment]
Regression caused by (bug #): 
User impact if declined: 
Testing completed (on m-c, etc.): 
Risk to taking this patch (and alternatives if risky):
String changes made by this patch:
Attachment #623780 - Flags: approval-mozilla-aurora?
Should this have gotten UX approval prior to landing?
(In reply to Aaron Train [:aaronmt] from comment #14)
> Should this have gotten UX approval prior to landing?

UX can always feedback, but as this is the simplest fix that doesn't change the current behavior for strings that are short enough to fit, I made the call.
Whiteboard: [inb
Whiteboard: [inb → [inbound]
https://hg.mozilla.org/mozilla-central/rev/18b2a189a84d
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Attachment #623780 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Whiteboard: [inbound]
Verified on 2012-05-07 Aurora and Beta 2 using a HTC Desire Z/G2. Cannot verify on Nightly due to localization happening on Aurora. Though as the same code was checked into m-c marking verified.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.