Autocomplete drop-down not invoked on certain Bugzilla fields

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
6 years ago
2 years ago

People

(Reporter: stormy, Unassigned)

Tracking

Trunk
ARM
Android
Points:
---

Firefox Tracking Flags

(blocking-fennec1.0 -)

Details

(Whiteboard: [Engagement])

(Reporter)

Description

6 years ago
You can't add a user to a bug in Fennec unless you know their exact username as the dropdown autocomplete list doesn't work. (It does work in the stock browser that came with my phone.)

Web page or screen you were on when you saw the issue: bugzilla.mozilla.org

Steps to reproduce:
1. Go to any bug in Mozilla.
2. Go to add user. Start typing in a user name. It does not autocomplete.

What you expected: The drop down box with names that match what I've typed so far.

(It works on the stock browser.)

Updated

6 years ago
tracking-fennec: --- → ?
OS: Mac OS X → Android
Hardware: x86 → ARM
Summary: Can't add a user to a bug in Fennec → Autocomplete drop-down not invoked on certain Bugzilla fields
blocking-fennec1.0: --- → ?
Chris - Is this a dupe?
blocking-fennec1.0: ? → -
Stormy, what type of phone are you using?

I tested my Droid Pro (with hardware keyboard) and Galaxy Note (with virtual keyboard). Username autocomplete worked correctly for both the "Assigned To" and "CC List Add" fields.
(Reporter)

Comment 3

6 years ago
It works now for me now on Nightly!

I'm using a Samsung Galaxy Nexus running Android 4.0.4.
Stormy, I'm closing WFM, but if you find specific repro steps for this problem, just let me know.

I had tested Nightly, so I just double-checked Aurora. Both channels work for me.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 5

6 years ago
it's not working. 

I'm wondering if earlier when i thought it was working, I was just seeing the existing list of names as i wasn't actually adding someone.

the only difference i can think of between earlier and now is that earlier i was on wifi and now (and the first time) i am on tmobile's network. I'll try again when i get home.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
A good way to distinguish Bugzilla's username suggestions from Fennec's list of text you've entered before is to use the Bugzilla username shortcuts with colon plus 2+ random letters. You'll see names and email addresses you've never entered before. :)

Updated

6 years ago
Status: REOPENED → RESOLVED
Last Resolved: 6 years ago6 years ago
Resolution: --- → WORKSFORME
(Assignee)

Updated

5 years ago
tracking-fennec: ? → ---
You need to log in before you can comment on or make changes to this bug.