Country Drop Down does not work on grubcanada.com

RESOLVED WORKSFORME

Status

()

Firefox for Android
General
RESOLVED WORKSFORME
6 years ago
2 years ago

People

(Reporter: Diana Livits, Unassigned)

Tracking

Trunk
ARM
Android
Points:
---

Firefox Tracking Flags

(fennec+)

Details

(Whiteboard: [Engagement])

(Reporter)

Description

6 years ago
Web page or screen you were on when you saw the issue: 

Steps to reproduce:
1. typed www.grubcanada.com
2. arrived on the page and clicked on the down arrow to select city
3. clicked a number of times and the drop down only appeared after 6 or 7 clicks

What you expected: 

I expected the list to drop down after the first click

Crash report ID (if applicable):
The drop-down appears .... behind the keyboard which is not very ideal or obvious. Content should scroll into view. Not sure which bug this a dupe of. Kats?
I don't think it's a dupe of any bug right now. We do scroll the text input field into view as desired. From the browser point of view the drop-down thing is just a regular <li> element and we have no way of knowing that it should be scrolled into view. The best we can do is try to center the input field on the available space, rather than scrolling so that it is at the bottom of the available space. That would leave at least some of the dropdown visible.

Updated

6 years ago
tracking-fennec: --- → ?
tracking-fennec: ? → +
I don't see a select a city anymore, they have enter your postal code and a 'I feel like eating' drop-down which works fine on first focus attempt. Resolving this as I haven't seen this issue on other sites.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.