Preferences localization support

RESOLVED FIXED in 1.11

Status

Add-on SDK
General
P2
normal
RESOLVED FIXED
6 years ago
5 years ago

People

(Reporter: Siavash, Assigned: ochameau)

Tracking

unspecified
1.11
x86_64
Linux

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
I mentioned this in the Google Groups some time ago, but thought it would be better to submit it here.

Developers should be able to localize package.json, e.g. for localizing preferences.

Updated

6 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
Priority: -- → P2
(Assignee)

Comment 1

6 years ago
Created attachment 656399 [details]
Pull request 538

Siavash, it looks like, the best way to get some traction from me is to subscribe to my twitter feed ;)

I ended up on you blog post here:
http://potatozone.com/en/2012/02/what-users-should-know-about-jetpack-add-ons/
And its quite unfortunate experience, let's try to improve it!
Assignee: nobody → poirot.alex
Attachment #656399 - Flags: review?(evold)
(Assignee)

Comment 2

6 years ago
I changed the focus of this bug to localize preferences stuff,
as we already have bug 661083 opened to localize other package.json fields.
Summary: package.json localization support → Preferences localization support
(Reporter)

Comment 3

6 years ago
(In reply to Alexandre Poirot (:ochameau) from comment #1)

> Siavash, it looks like, the best way to get some traction from me is to
> subscribe to my twitter feed ;)

I'm glad to hear this, though that wasn't my intention :)

Comment 4

6 years ago
Commits pushed to master at https://github.com/mozilla/addon-sdk

https://github.com/mozilla/addon-sdk/commit/cd4968c8b66ab21ef11b22a5f1a6edfd5f60386c
Bug 754032: Localize preferences

https://github.com/mozilla/addon-sdk/commit/421aee905ee2150b8e5926477fdf0e6aeb88fc7e
Merge pull request #538 from ochameau/bug/754032-preferences-l10n

Fix Bug 754032: Localize preferences r=erikvold

Updated

6 years ago
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
(Assignee)

Updated

6 years ago
Target Milestone: --- → 1.11
(Assignee)

Comment 5

6 years ago
Siavash, It would be really cool if you can take a look at this and confirm that you are now able to locale some of your addons.
(Reporter)

Comment 6

6 years ago
(In reply to Alexandre Poirot (:ochameau) from comment #5)
> Siavash, It would be really cool if you can take a look at this and confirm
> that you are now able to locale some of your addons.

I tested it on a simple add-on, then tried it on one of my add-ons and it works.

I noticed that if I use a locale that add-on doesn't support, it uses en-US and if en-US localization doesn't exist, it uses the values from package.json. Does this mean that if the current Firefox's locale isn't supported by add-on, values from package.json will be used?
(Assignee)

Comment 7

6 years ago
(In reply to Siavash from comment #6)
> I noticed that if I use a locale that add-on doesn't support, it uses en-US
> and if en-US localization doesn't exist, it uses the values from
> package.json. Does this mean that if the current Firefox's locale isn't
> supported by add-on, values from package.json will be used?

Yes. Can you take a look at bug 779790 and see if it would address what you feel like being unclear/wrong here?
Attachment #656399 - Flags: review?(evold) → review+
You need to log in before you can comment on or make changes to this bug.