Clicking the Back button from this page crashes Moz

VERIFIED WORKSFORME

Status

()

Core
ImageLib
VERIFIED WORKSFORME
17 years ago
17 years ago

People

(Reporter: Frank Burleigh, Assigned: Stuart Parmenter)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [imglib], URL)

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; 0.8.1)
BuildID:    2001041004

The browser crashes with A/V dialog after *returning* to this page from one of
the pages linked *on* this page.

Reproducible: Always
Steps to Reproduce:
1. Visit the page.
2. Click the "Netware 6 and MP" link.
3. Click the back button
4. You should see an access violation-type of dialog.

Actual Results:  Crashed browser.

Expected Results:  Normal back behavior.

There are several other back button crashers in bugzilla, one owned by darin
seems to involve javascript, another involves OJI (java).  So I made this a new
bug, as this page seems to use javascript only for image loading.

Comment 1

17 years ago
Seeing with PC Linux 2001041005.
For me it crashes when I click "Netware and MP" link.

Comment 2

17 years ago
Created attachment 30319 [details]
Linux stack trace

Updated

17 years ago
Assignee: asa → pavlov
Status: UNCONFIRMED → NEW
Component: Browser-General → ImageLib
Ever confirmed: true
QA Contact: doronr → tpreston

Comment 3

17 years ago
GetMappedAttributeImpact()
libimglib2.so + 0x6645 (0x4104e645)
libimglib2.so + 0x4d5c (0x4104cd5c)
libimglib2.so + 0x63f0 (0x4104e3f0)
libimglib2.so + 0x464d (0x4104c64d)
nsHTMLInputElement::GetElementsByTagName()
nsHTMLInputElement::HandleDOMEvent()
LocationImpl::SetPort()
NS_InitHTMLHeadElementClass()
js_DeleteProperty()
js_Interpret()
ImportProperty()
JS_NewStringCopyN()
NS_InitDOMExceptionClass() 
nsHTMLDocument::QueryInterface() 
nsHTMLDocument::StartDocumentLoad() 
libglib-1.2.so.0 + 0x10751 (0x40636751)
libglib-1.2.so.0 + 0x108f1 (0x406368f1)
libgtk-1.2.so.0 + 0x8c8e9 (0x4055e8e9)
nsButton::SetFontNative() 
nsAppShellService::DestroyExitEvent() 
InitializeProfileService()  
main1()
libc.so.6 + 0x189cb (0x401e99cb)  

Updated

17 years ago
Whiteboard: [imglib]
(Assignee)

Comment 4

17 years ago
works for me with todays build
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME

Comment 5

17 years ago
same here: worksforme with PC Linux 2001041605.

Comment 6

17 years ago
Verified fixed w2k build 2001081003
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.