If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

GCLI needs a way to execute os level commands (part 2)

RESOLVED FIXED in Future

Status

()

Firefox
Developer Tools: Graphic Commandline and Toolbar
P4
normal
RESOLVED FIXED
5 years ago
4 years ago

People

(Reporter: jwalker, Assigned: jwalker)

Tracking

unspecified
Future
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Bug 729514 started this work, and was merged early to prevent bitrot.
This bug continues the work.
Depends on: 740429
New component triage. Filter on "Lobster Thermidor aux crevettes with a Mornay sauce"
Component: Developer Tools: Console → Developer Tools: Graphic Commandline and Toolbar
Duplicate of this bug: 767381
Created attachment 753640 [details] [diff] [review]
v1

This patch has been hanging around for ages. It doesn't actually add an exec command in Firefox (bug 874795 finishes off the last piece of that) but it does lay the groundwork for that, and it is used by bug 874821 which is what I'd really like to land.

The individual commits are in https://github.com/joewalker/gcli/pull/11 although most of them don't reach Firefox, so this patch is probably the best thing to look at.
Assignee: nobody → jwalker
Status: NEW → ASSIGNED
Attachment #753640 - Flags: review?(mratcliffe)
Blocks: 874821
https://tbpl.mozilla.org/?tree=Try&rev=c8cae83af9e2
Attachment #753640 - Flags: review?(mratcliffe) → review+
https://tbpl.mozilla.org/?tree=Fx-Team&rev=dea12c804f30
https://hg.mozilla.org/integration/fx-team/rev/c0e82dcf80e7
Whiteboard: [fixed-in-fx-team]
https://hg.mozilla.org/mozilla-central/rev/c0e82dcf80e7
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Whiteboard: [fixed-in-fx-team]
You need to log in before you can comment on or make changes to this bug.