Cancelling the master password prompt should not trigger window.onerror

RESOLVED DUPLICATE of bug 541849

Status

()

Core
General
RESOLVED DUPLICATE of bug 541849
6 years ago
4 years ago

People

(Reporter: Roman, Unassigned)

Tracking

Trunk
x86
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
"window.onerror" should probably not be triggered by errors thrown in the browser chrome.

If the goal is to log a message to the console, there are surely ways of doing that which do not trigger window.onerror.

At the very least, the "url" parameter passed in should clearly identify the source of the error as the browser chrome, so that I can filter it out and avoid reporting it as an error in my website.
(Reporter)

Updated

6 years ago
Summary: Aborting the login manager should not trigger window.onerror → Cancelling the master password prompt should not trigger window.onerror
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 541849
You need to log in before you can comment on or make changes to this bug.