Last Comment Bug 75452 - Save last "created in" folder as default
: Save last "created in" folder as default
Status: RESOLVED EXPIRED
:
Product: SeaMonkey
Classification: Client Software
Component: Bookmarks & History (show other bugs)
: Trunk
: All All
: P3 enhancement (vote)
: Future
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
: 106652 (view as bug list)
Depends on: 158648
Blocks:
  Show dependency treegraph
 
Reported: 2001-04-10 14:39 PDT by Matthew Cline
Modified: 2010-04-28 13:32 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments

Description Matthew Cline 2001-04-10 14:39:33 PDT
Often, I'll be searching on a certain subject and bookmarking all the
useful pages I find, all into the same folder, and I have to select that
same folder over and over again, which usually involves scrolling down
the list.  It'd be nice if there was an option to say "remember the
last folder I created a bookmark in", and that folder would be selected
by default, visible in the list of folders and highlighted.
Comment 1 Claudius Gayle 2001-04-11 14:23:01 PDT
i'd imagine the simplest most straightforward way would be to simply always remember
where the last one was and put you back there - like every other good chooser/file picker
widget in the world does.
Comment 2 Ben Goodger (use ben at mozilla dot org for email) 2001-10-19 17:26:31 PDT
Paul Chen is now taking Bookmarks bugs. For your convenience, you can filter 
email notifications caused by this by searching for 'ilikegoats'.

Comment 3 Paul Chen 2001-11-05 15:07:36 PST
certainly file bookmark should work that way, not so sure add bookmark should
always work that way, marking future
Comment 4 Peter Trudelle 2002-01-05 15:31:19 PST
mass reassign of pchen bookmark bugs to ben
Comment 5 Boris 'pi' Piwinger 2002-05-29 05:46:47 PDT
*** Bug 106652 has been marked as a duplicate of this bug. ***
Comment 6 Jesse Ruderman 2002-08-06 18:45:32 PDT
See also bug 111972, which would add "Set as Folder for New Bookmarks" or
something similar.
Comment 7 mmortal03 2003-12-29 01:14:53 PST
As of the most recent nightly branch builds (for example 20031227) this bug is "partially" fixed, but I think it has been for a while now.  By "partially", I mean that the browser remembers the last used "Create In" bookmark folder, but only during the current process.  After the browser is closed, it reverts back to the Last Modified folder, but this excludes the root "Bookmarks" folder.  It will not remember the root "Bookmarks" folder.

Oddly enough, I think I recall that previous versions (before the new Add Bookmark window was added) DID remember the last used "Create In" folder, but I may be wrong.  The reason I say this is because I am now missing it for some reason.  Hmm, maybe it was never there, I will try to test previous versions to see.
Comment 8 Henrik Skupin (:whimboo) 2004-02-07 06:06:01 PST
*** Bug 232467 has been marked as a duplicate of this bug. ***
Comment 9 mmortal03 2004-02-29 14:01:12 PST
(In reply to comment #7)
I was speaking of Firefox in my previous comment.  This bug report is not for Firefox, though Firefox does have the same issue.  Should a similar bug report be submitted for Firefox?
Comment 10 Robert Kaiser (not working on stability any more) 2009-06-14 08:53:17 PDT
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614
Comment 11 Robert Kaiser (not working on stability any more) 2009-06-14 08:58:08 PDT
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614
Comment 12 Robert Kaiser (not working on stability any more) 2009-06-14 09:04:15 PDT
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614
Comment 13 Robert Kaiser (not working on stability any more) 2009-06-14 10:01:42 PDT
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614
Comment 14 Robert Kaiser (not working on stability any more) 2009-06-14 10:08:16 PDT
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614
Comment 15 Robert Kaiser (not working on stability any more) 2010-04-28 13:32:04 PDT
MASS-CHANGE:
This bug report is registered in the SeaMonkey product, but still has no comment since the inception of the SeaMonkey project 5 years ago.

Because of this, we're resolving the bug as EXPIRED.

If you still can reproduce the bug on SeaMonkey 2 or otherwise think it's still valid, please REOPEN it and if it is a platform or toolkit issue, move it to the according component.

Query tag for this change: EXPIRED-20100420

Note You need to log in before you can comment on or make changes to this bug.