Last Comment Bug 754556 - Twitchy element positioning when scrolling
: Twitchy element positioning when scrolling
Status: RESOLVED FIXED
: regression
Product: Core
Classification: Components
Component: Layout (show other bugs)
: 15 Branch
: x86 All
-- normal (vote)
: mozilla15
Assigned To: Robert O'Callahan (:roc) (email my personal email if necessary)
:
: Jet Villegas (:jet)
Mentors:
http://board.byuu.org/viewtopic.php?p...
Depends on:
Blocks: 681192
  Show dependency treegraph
 
Reported: 2012-05-12 03:22 PDT by Bram Speeckaert
Modified: 2012-05-23 08:05 PDT (History)
6 users (show)
ryanvm: in‑testsuite+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Screenshot 1 (72.27 KB, image/png)
2012-05-12 03:23 PDT, Bram Speeckaert
no flags Details
Screenshot 2 (73.93 KB, image/png)
2012-05-12 03:23 PDT, Bram Speeckaert
no flags Details
fix (11.86 KB, patch)
2012-05-14 04:01 PDT, Robert O'Callahan (:roc) (email my personal email if necessary)
no flags Details | Diff | Splinter Review
better patch (11.33 KB, patch)
2012-05-14 05:24 PDT, Robert O'Callahan (:roc) (email my personal email if necessary)
mats: review+
Details | Diff | Splinter Review
nsScrollBoxObject fix (1.21 KB, patch)
2012-05-14 17:35 PDT, Robert O'Callahan (:roc) (email my personal email if necessary)
mats: review+
Details | Diff | Splinter Review
fix (4.01 KB, patch)
2012-05-21 23:31 PDT, Robert O'Callahan (:roc) (email my personal email if necessary)
mats: review+
Details | Diff | Splinter Review

Description User image Bram Speeckaert 2012-05-12 03:22:33 PDT
STR:
1. Open the following URL: http://board.byuu.org/viewtopic.php?p=64035#p64035
2. Scroll all the way down
3. Start autoscrolling and try to scroll downwards
4. Try moving the mouse pointer around for a bit (but keep it below where you started autoscrolling, as if you're still trying to make the page go down more)
5. Alternatively enter Full Screen and watch how the page elements behave

In certain spots some of the page elements continuously start twitching up and down. I have attached screenshots showcasing the behavior.

Observed on lastest Nightly on Windows XP and Windows 7 64-bit.
Comment 1 User image Bram Speeckaert 2012-05-12 03:23:09 PDT
Created attachment 623409 [details]
Screenshot 1
Comment 2 User image Bram Speeckaert 2012-05-12 03:23:40 PDT
Created attachment 623410 [details]
Screenshot 2
Comment 3 User image Alice0775 White 2012-05-12 04:38:07 PDT
Regression window(m-c)
Cannot reproduce:
http://hg.mozilla.org/mozilla-central/rev/6fe7dd2f8f57
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:15.0) Gecko/15.0 Firefox/15.0a1 ID:20120510021321
Reproduce:
http://hg.mozilla.org/mozilla-central/rev/b7b6565d12a0
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:15.0) Gecko/15.0 Firefox/15.0a1 ID:20120510050721
Pushlog;
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=6fe7dd2f8f57&tochange=b7b6565d12a0



Regression window(m-i
Cannot reproduce:
http://hg.mozilla.org/integration/mozilla-inbound/rev/b5304fd23df9
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:15.0) Gecko/15.0 Firefox/15.0a1 ID:20120509222721
Reproduce:
http://hg.mozilla.org/integration/mozilla-inbound/rev/67091352b7d2
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:15.0) Gecko/15.0 Firefox/15.0a1 ID:20120509223521
Pushlog;
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=b5304fd23df9&tochange=67091352b7d2

Triggered by:Bug 681192
Comment 4 User image Alice0775 White 2012-05-12 05:09:57 PDT
I can also reproduce on Linux
http://hg.mozilla.org/mozilla-central/rev/22a58090fa70
Mozilla/5.0 (X11; Linux x86_64; rv:15.0) Gecko/15 Firefox/15.0a1 ID:20120512030520
Comment 5 User image Alice0775 White 2012-05-12 05:57:42 PDT
screen capture http://youtu.be/YFSD3n3bYvk
Comment 6 User image Alice0775 White 2012-05-12 08:16:52 PDT
Last good: c3d3bfb3b68d
First bad: 9d9a3edaa0b9
Comment 7 User image Robert O'Callahan (:roc) (email my personal email if necessary) 2012-05-14 04:01:03 PDT
Created attachment 623625 [details] [diff] [review]
fix
Comment 8 User image Robert O'Callahan (:roc) (email my personal email if necessary) 2012-05-14 05:24:25 PDT
Created attachment 623639 [details] [diff] [review]
better patch
Comment 9 User image Mats Palmgren (:mats) 2012-05-14 12:48:59 PDT
Comment on attachment 623639 [details] [diff] [review]
better patch

>layout/generic/nsIScrollableFrame.h
>+  virtual void ScrollToCSSPixels(nsIntPoint aScrollPosition) = 0;

Please add to the doc comment that the scroll mode is INSTANT.

Shouldn't nsScrollBoxObject::ScrollTo change in same way?
Comment 10 User image Robert O'Callahan (:roc) (email my personal email if necessary) 2012-05-14 14:37:27 PDT
Yes, I'll do that separately.
Comment 11 User image Robert O'Callahan (:roc) (email my personal email if necessary) 2012-05-14 17:35:24 PDT
Created attachment 623885 [details] [diff] [review]
nsScrollBoxObject fix
Comment 12 User image Robert O'Callahan (:roc) (email my personal email if necessary) 2012-05-14 22:59:29 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/3bd87d01b52e
Comment 13 User image Mats Palmgren (:mats) 2012-05-15 04:02:21 PDT
Comment on attachment 623885 [details] [diff] [review]
nsScrollBoxObject fix

r=mats
Comment 14 User image Ed Morley [:emorley] 2012-05-15 06:27:07 PDT
https://hg.mozilla.org/mozilla-central/rev/3bd87d01b52e
Comment 15 User image Robert O'Callahan (:roc) (email my personal email if necessary) 2012-05-15 22:55:00 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/75840c5beb37
Comment 16 User image Ryan VanderMeulen [:RyanVM] 2012-05-16 19:26:06 PDT
https://hg.mozilla.org/mozilla-central/rev/75840c5beb37
Comment 17 User image Daniel Cater 2012-05-19 10:14:59 PDT
Fx 15.0a1 2012-05-19

I can still reproduce parts of this, although it is fixed for autoscrolling.

Using the same URL, or one of quite a few others (http://www.less-broken.com/blog/2012/05/no-www-considered-harmful.html is one example), I can reproduce twitchy elements using the following steps:

1. Scroll to the bottom of the page with the mouse wheel.
2. Scroll down some more with the mouse wheel.

(Alternative to step 2 is scroll left with a tilt-wheel, if you have one).

This doesn't happen every time, but fairly often.

(I have no idea why the blocker got removed, thanks Ryan).
Comment 18 User image Ryan VanderMeulen [:RyanVM] 2012-05-19 10:15:58 PDT
bmo issues
Comment 19 User image Alice0775 White 2012-05-19 15:46:58 PDT
Confirmed with STR(Alternative to step 2 is scroll left) of comment #17 in
http://hg.mozilla.org/mozilla-central/rev/642d1a36702f
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:15.0) Gecko/15.0 Firefox/15.0a1 ID:20120519030527
Comment 20 User image Robert O'Callahan (:roc) (email my personal email if necessary) 2012-05-21 23:31:43 PDT
Created attachment 625905 [details] [diff] [review]
fix
Comment 21 User image Robert O'Callahan (:roc) (email my personal email if necessary) 2012-05-22 02:59:29 PDT
http://hg.mozilla.org/integration/mozilla-inbound/rev/c34c675c61d6
Comment 22 User image Ed Morley [:emorley] 2012-05-23 08:05:20 PDT
https://hg.mozilla.org/mozilla-central/rev/c34c675c61d6

Note You need to log in before you can comment on or make changes to this bug.