Closed Bug 754585 Opened 9 years ago Closed 8 years ago

Fennec Nightly failing ACID3 test (with one error)

Categories

(Firefox for Android :: General, defect)

ARM
Android
defect
Not set
normal

Tracking

()

VERIFIED FIXED
Firefox 16
Tracking Status
firefox14 --- verified
firefox15 --- verified
firefox16 --- verified

People

(Reporter: Tobbi, Assigned: mfinkle)

References

(Depends on 1 open bug)

Details

Attachments

(1 file)

When running the acid3 test with nightly, I get 99/100 with the following error:
Test 47 failed: expected 'auto' but got 'none' - control failed.

Additionally, you see "You should not see this at all" in red font in the test result.
Duplicate of this bug: 754601
> Test 47 failed: expected 'auto' but got 'none' - control failed.

This isn't actually part of the test.  It's part of the test prerequisites: for test 47 to make sense as it's currently written, the computed 'cursor' value on the body must be "auto" (the initial value) if there are no other styles set by the page.

Fennec has the following rule in its UA stylesheet:

45 html|*:-moz-system-metric(touch-enabled) {
46   cursor: none !important;
47 }

which of course means that test 47 is meaningless.  And the test harness treats the meaninglessness as a test failure.

Arguably, this is a bug in the test.  I've e-mailed hixie about that.

> Additionally, you see "You should not see this at all"

There's an existing bug on this, I think...
hixie is claiming that the cursor:none rule is a bug, fwiw, and refusing to fix the test.  Mark, up to you to fight that battle if you want to....
Blocks: 472426
Product: Core → Fennec
QA Contact: general → general
Version: unspecified → Trunk
Blocks: acid3
This has the danger of making people say that Firefox for Android is buggy and giving it bad props for that, esp. as we are also already worse than some other browsers when it comes to the html5test stuff people like to cite for "browser quality" these days. And yes, being measured in results of those benchmarks sucks at times, but it's what happens in reality quite a bit.
Fortunately, we have an edge in speed right now on Android, but we wouldn't want people to water it by reporting "missing modern web functionality".
Boris - Thanks for pin-pointing the reason for the failure. I removed the override just to see what would happen. Fennec does score 100/100 _and_ does not show the cursor. My guess is that the OMTC and GL changes removed the need to hide the cursor. Patch coming up.
Attached patch patchSplinter Review
This patch removes the cursor.css UA stylesheet file and the code that loads it. We score 100/100 on acid 3 and I don't see a cursor when tapping around web pages.
Assignee: nobody → mark.finkle
Attachment #638149 - Flags: review?(mbrubeck)
Attachment #638149 - Flags: review?(mbrubeck) → review+
Product: Fennec → Fennec Native
OS: Windows XP → Android
Hardware: x86 → ARM
https://hg.mozilla.org/mozilla-central/rev/ce75fa1a043e
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 16
Comment on attachment 638149 [details] [diff] [review]
patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): old code in fennec
User impact if declined: none. the impact is purely for hitting 100% in a benchmark
Testing completed (on m-c, etc.): minimal
Risk to taking this patch (and alternatives if risky): the code that was removed seemed to have no effect anymore. it was only needed in XUL fennec back before shadow layers was implemented.
String or UUID changes made by this patch: none
Attachment #638149 - Flags: approval-mozilla-beta?
Attachment #638149 - Flags: approval-mozilla-aurora?
(In reply to Mark Finkle (:mfinkle) from comment #7)
> https://hg.mozilla.org/integration/mozilla-inbound/rev/ce75fa1a043e
> 
> CC'ing Vivien in case this affects b2g as well

Thanks for the CC. It doesn't since we don't use cursor.css on B2G.
Comment on attachment 638149 [details] [diff] [review]
patch

[Triage Comment]
Looks like a very simple removal of unused code - approving for Aurora 15 and Beta 14(.0.1).
Attachment #638149 - Flags: approval-mozilla-beta?
Attachment #638149 - Flags: approval-mozilla-beta+
Attachment #638149 - Flags: approval-mozilla-aurora?
Attachment #638149 - Flags: approval-mozilla-aurora+
100% across the board, verified fixed on m-c (07/10), m-a (07/10), m-b (14.0 Beta 12, Build #1)
Depends on: 793890
You need to log in before you can comment on or make changes to this bug.