[New Tab Page] Thumbnails cannot handle position:fixed well

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
7 years ago
4 years ago

People

(Reporter: jara.karel, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
Created attachment 623493 [details]
Problem with thumbnail of Google+

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:13.0) Gecko/20100101 Firefox/13.0
Build ID: 20120509070325

Steps to reproduce:

Open new tab with the New Tab Page. You have e.g. Facebook and Google+ there which use position:fixed for some parts of the page. You visit the page and scroll somewhere down.


Actual results:

The thumbnail on New Tab Page is broken. It shows the position:fixed elements elsewhere than they are if you see the page in the browser. They are shifted according to where you scroll and the non-fixed parts which should not be visible are starting at the top of the thumbnail.


Expected results:

The thumbnail should look the same way as the page in a browser.
Component: Untriaged → Tabbed Browser
QA Contact: untriaged → tabbed.browser
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows 7 → All
Hardware: x86_64 → All
Version: 13 Branch → Trunk
The problem is that Firefox cannot handle any
Oops, I haven't finish my last comment...

The problem is that Firefox cannot handle any element whose position is changed when scrolling, not only those with position:fixed. We expect it to have the thumbnail look the same as what we see when it scrolls to the top, but it just capture in an arbitrary state.
Mass-move to Firefox::New Tab Page.

Filter on new-tab-page-component.
Component: Tabbed Browser → New Tab Page
Has this stopped for you in a newer version?
Flags: needinfo?(quanxunzhen)
Flags: needinfo?(jara.karel)
I guess it probably works fine now, because at least the thumbnail of DXR always looks correct to me.
Flags: needinfo?(quanxunzhen)

Updated

4 years ago
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Flags: needinfo?(jara.karel)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.