Closed Bug 75470 Opened 19 years ago Closed 18 years ago

Add bookmarks dialog should remember its position

Categories

(SeaMonkey :: Bookmarks & History, defect, P4)

PowerPC
Mac System 8.5
defect

Tracking

(Not tracked)

VERIFIED WORKSFORME
mozilla1.0

People

(Reporter: sfraser_bugs, Assigned: paulkchen)

Details

(Whiteboard: fix in hand, needs review)

Attachments

(1 file)

The Add Bookmarks dialog should be resizable, so that you can stretch it out to 
see more of the tree. It should also remember its last size and position.
This patch does the following:
1. Fixes the openDialog flags to make the window resizable, and look more like a 
dialog.
2. Persists size and position of the window
3. Changes box flex in a couple of places so that resizing the window makes the 
tree get bigger.

Reviews, please.
Keywords: patch
Whiteboard: fix in hand, needs review
r=ben@netscape.com. .9, will apply to tree and check in with my other stuff. 
Status: NEW → ASSIGNED
Target Milestone: --- → mozilla0.9
Looks copacetic to me, too. r=pchen.
sr=sfraser if you like.
booya
Status: ASSIGNED → RESOLVED
Closed: 19 years ago
Resolution: --- → FIXED
Reopening. Ben, you failed to check in this bookmarksOverlay.js part, so the 
dialog still looks weird.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Target Milestone: mozilla0.9 → mozilla0.9.1
nav triage team:

Ben, check that file in!
Keywords: nsbeta1+
Priority: -- → P1
Target Milestone: mozilla0.9.1 → mozilla0.9.2
Ben today's changes haven't taken into account the dialog=yes change to
bookmarksOverlay.js. Do we still want to do that?
Yes we do.
Ben promised to fix this, the patch is in the bug.
oy. This bug is like a turd that won't flush. Accepting. Triage team, this is
trivial, don't minus, it takes like 5 mins to fix & checkin ;) 
Status: REOPENED → ASSIGNED
I just checked this in. I got all 3 places we bring up addBookmarks.xul.
Status: ASSIGNED → RESOLVED
Closed: 19 years ago19 years ago
Resolution: --- → FIXED
I hate to reopen this bug but based on Simon's opening comments when filing this bug it is
not fixed. The add/file bookmark dialog now resizes and persists its size but does not persist
its position. It resets its position to center on each occasion. I tested this by invoking it, moving
and sizing it, and cancelling it.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Erk.
Summary: Add bookmarks dialog should be resizeable → Add bookmarks dialog should remember its position
2001051504 builds, btw
nav triage team:

Marking nsbeta1+, p4, and mozilla0.9.3
Priority: P1 → P4
Target Milestone: mozilla0.9.2 → mozilla0.9.3
nav triage team:

Not a 0.9.3 stopper, marking mozilla1.0
Target Milestone: mozilla0.9.3 → mozilla1.0
Hardware: All → Macintosh
Paul Chen is now taking Bookmarks bugs. For your convenience, you can filter 
email notifications caused by this by searching for 'ilikegoats'.

Assignee: ben → pchen
Status: REOPENED → NEW
worksforme using my debug build from this morning, marking w4m
Status: NEW → RESOLVED
Closed: 19 years ago18 years ago
Resolution: --- → WORKSFORME
mass-verifying WorksForMe bugs which haven't changed since 2001.12.31.

set your search string in mail to "EmperorLondoMollari" to filter out these
messages.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.