Closed Bug 754750 Opened 11 years ago Closed 8 years ago

Google Finance - Suboptimal site, not optimized site renders on Fennec Native Due to UA sniffing and XHTML content-type

Categories

(Web Compatibility :: Mobile, defect)

ARM
Android
defect
Not set
normal

Tracking

(blocking-kilimanjaro:+)

RESOLVED INVALID
blocking-kilimanjaro +

People

(Reporter: jsmith, Assigned: karlcow)

References

()

Details

(Whiteboard: [sitewait] [country-all] [serversniff])

Attachments

(4 files)

If a user goes to finance.google.com on fennec native, they will end up getting an outdated suboptimal mobile site that does allow chart viewing. On the stock browser, finance.google.com is renders a different site optimized for mobile. User agent sniffing is evident here (see screenshots).

Changing the user agent on fennec native to the android stock browser sends a warning to the user saying the following:

"Unsupported Firefox version. Minimum required version is 1.5. Continue at your own risk"

Using the site with the UA changes at first glance only showed very minor issues though (only issue seen so far is that the select box alignment is incorrect).
No longer blocks: google-evangelism
blocking-kilimanjaro: --- → +
Going to google.com/finance or finance.google.com yields 'No Results found for null' and continues to return zero results for any query. Their site is completely busted with our user-agent.
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 679025
Not a duplicate. This is about the user agent sniffing, the other bug is about "null" error being shown.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Component: Evangelism → Mobile
Product: Firefox for Android → Tech Evangelism
Version: Firefox 15 → unspecified
Status: REOPENED → NEW
Assignee: nobody → kdubost
Whiteboard: [contactready] [country-all] [serversniff]
See Also: → 679025
Right now the graph doesn't load at all. I have already contacted Google about Bug 679025
Karl - the state of this bug confuses me somewhat. Is the "graph not loading" a new issue that needs analysis, or is it the issue this [contactready] bug is all about?

Looking.. if spoofing HTTP (only) as Android browser, it does indeed load till a point where it says "no  chart available" - i.e. works much better but not perfect. Searching for a specific stock (while spoofing) will render a chart.
Confused, two we are. ;)

(all of these are done not logged with a Google account)

* Using Firefox for Android. 23.0
Phone: GT-I9100. Android version 2.3.5
Clear private data.

So. Currently when loading this page in Firefox for Android, I get a rainbow wheel for ever.
Let's say I put the NDX quote and enter. Nothing happens. Infinite wheel. 
URL is http://google.com/m/finance#search/Ndx

Markets and Portfolio give nothing. News gives a list of news.

* Using Android Stock Browser. I get a market summary.
Entering Ndx leads me to the graph of this symbol and associated news.
all other buttons are working

* Using Opera Mobile
Clear cookies. Exact same successful experience than Android Browser.
Per my testing yesterday it seems there still is backend sniffing, and this is still blocking required functionality. So I think you can just keep working on getting contacts..
fwiw I still push this bug in parallel through the comments on Bug 679025

I will put sitewait to not be confused.
Status: NEW → ASSIGNED
Whiteboard: [contactready] [country-all] [serversniff] → [sitewait] [country-all] [serversniff]
See Also: → 1002690
Testing again today in the wake of Bug 1002690
I get the Desktop site when entering http://www.google.com/finance?q=NASDAQ:GOOG
See Screenshot
When entering manually the address
https://www.google.com/m/finance
We still receive an infinite spinning wheel and some buttons not working. So I was wondering what was happening on the network. 

1 HTTP POST is made which receives from the server a 400 Illegal parameters [Cause: null]

The URI was.
https://www.google.com/finance/qs/channel?VER=8&SID=59D0D897EEF6C313&RID=43737&AID=0&zx=5pv9lj3geppy&t=1

The HTTP Request 
Host: www.google.com
User-Agent: Mozilla/5.0 (Android; Mobile; rv:30.0) Gecko/30.0 Firefox/30.0
Accept: text/html,application/xhtml+xml,application/xml;q=0.9,*/*;q=0.8
Accept-Language: en-US,en;q=0.5
Accept-Encoding: gzip, deflate
Content-Type: application/x-www-form-urlencoded; charset=UTF-8
Referer: https://www.google.com/m/finance
Content-Length: 13
Cookie: _ga=GA1.2-2.2013091068.1398827213; SC=RV=:ED=us; NID=67=W9jvVbkhdFX8TypLmUq0A7pQSiUNr8I01stxCVXbvOzsdCQZvjZneZHksxI2rQeWWuXiBxZiYeUcUu2y4stvn2TvixB0yk3nPHg0m6CUOWlKzDOs9axQ1VXV5JAP5EqI; PREF=ID=8dca95d5292a3be7:U=fd6a2ad3d7aec65a:TM=1398827212:LM=1398827219:S=4gKqp4e96oganLns; S=quotestreamer=Niah1cF3iiEgvxovk_lsrg; MPRF=H4sIAAAAAAAAAKv42v6i5bZGFxPDJCYFY7PENAvL1ETTRIvUlBQDU6M0wyTLNAPz5CTLxFQzA4MJzAwAIGCOsDAAAAA
Connection: keep-alive
Pragma: no-cache
Cache-Control: no-cache
Opera (Blink) spoofing as iPhone sends this POST body:

count=1&ofs=0&req0_INDEXDJX:.DJI=&req0_INDEXSP:.INX=&req0_INDEXNASDAQ:.IXIC=

and gets 

HTTP/1.1 200 OK

Both Firefox and Opera when spoofing as Firefox on Android sends only 

count=1&ofs=0

and gets the 400 "illegal parameter" response.

Firefox gets the main page sent with Content-Type: application/xhtml+xml; charset=UTF-8, other UAs I tested get text/html. This matters - if I take the response Firefox gets and replace the XHTML content type header with the HTML one, the next requests load without the 400 error and the page works much better.
Summary: Google Finance - Suboptimal site, not optimized site renders on Fennec Native Due to UA sniffing → Google Finance - Suboptimal site, not optimized site renders on Fennec Native Due to UA sniffing and XHTML content-type
Is there still a version of Google Finance for Mobile?
1. Faking Chrome Mobile Android UA on Desktop.
2. Going to https://www.google.com/finance or https://www.google.com/m/finance
3. I receive the desktop content on https://www.google.com/finance

Same thing on the Safari iPod Touch.

INVALID now?
Desktop Content on Safari iOS 8
Desktop Content on Firefox/Chrome Nexus 7 Android 4.4


http://cl.ly/image/2T1N2G261h2g
Thanks. Guillaume. I will close as INVALID.
Status: ASSIGNED → RESOLVED
Closed: 10 years ago8 years ago
Resolution: --- → INVALID
Product: Tech Evangelism → Web Compatibility
You need to log in before you can comment on or make changes to this bug.